Banana PI M5 don't boot

Good morning,

I recently purchased a Banana Pi BPI-M5 Amlogic S905X3.

I can’t start / boot it, I have connected it to HDMI and a keyboard and mouse.

I would like to specify that this is the first time I have purchased such a device.

I tried several micro SD cards, HDMI cables, I also installed many images, going from debian, armbian to ubuntu.

However nothing happens.

I don’t think the problem is with the power supply.

It is a USB Type C power supply of 15.3 Watts.

I’m a bit confused and a total beginner, I hope I didn’t do anything wrong.

Thanks for your help ^^

Mine won’t boot unless I connect a serial console cable. I don’t actually have to open a serial terminal, I just have to plug in both ends of the cable. The M5 then works fine, booting from SD or EMMC, driving the HDMI output, etc. But if I unplug the serial cable it won’t boot. It doesn’t get past the initial turning on of the three LEDs solid. I’ve tried several different 5V 3A power supplies and cables without any joy. Maybe the USB serial cable putting in some additional power somehow??

Replying to myself … this only applies to images built on the 5.1 kernel. Images built on the kernel work fine without a serial console cable connected.

Unfortunately I have yet to find one that supports my specific requirements: using a USB wireless dongle and supporting libcec4. (I have tried two wireless dongles, both based on RealTek chips - RTL8812BU and RTL8188CUS.)

The Armbian images support the wifi chips,images from the other sources don’t. But Armbian doesn’t support libcec4/cec-client even if I compile from source directly on the M5.

Any other Linux (except perhaps vendors private) provides this?