Banana pi BPI-W2's second ethernet port support

i’v tried a lot of times, and finaly drived the second ethernet port. u should just change the source code of driver realtek r8169soc-bananapi and change the device tree.

later i will push my code to my repositories:

wish bpi to be better in software!

1 Like

very thank you for you support .

i think it shoud be your job… what i changed may give up the function of hw-nat, just drive the second ethernet port .

for 2nd etherend port support , please see kernel 4.4 BSP, we have fixed it at kernel 4.4,You’ve been invited to join . thank you .

driver source code in 4.9.119 is the same with 4.4 bsp, and it’s not drived when kernel updated.

I’ve push my change to git repository. You can review it .

Could you also release the 4.4 source code? I want to take a look

Pls find W2 kernel 4.4 image with 2nd lan function by

Because above image supports both W2 & M4 models, pls adopt bpi-bootsel to select kernel 4.4 or adopt bpi-update -c bpi-w2-linux4.4.conf for updating current image.

If you want to get up-to-date code, pls provide your github account, we’ll add yours on W2 project thus you will see latest code updating in time.

Hi, please add me [] , I have some experience on working with kernel and porting OS to ARM boards, I will see what I can help.

edit: got it, thank you.

OK, have add you on github BPI-W2 kernel 4.4 BSP

Why you don’t make this repo public? Can I fork it, making changes/update and publish it publicly?

kernel 4.4 BSP Code is not good enough and difficult to maintain, and the original factory is upgrading this 4.4 to 4.9, because the display of this version 4.4 is not standard, which may easily cause trouble for ordinary users

This 4.4 BSP code is suitable for undisplayed or experienced user ,We’re open to anyone who needs it

Only suitable for people with development experience, We’re open to anyone who needs it.

thank you so much! is it affect sata availability?

it‘s just for second ether port, not others!

so, SATA wouldn’t be working after this patch?

Hi, could you please send me a link to the 4.4 repo as well, as I’m trying to use the second ethernet port on 4.9 kernel and want to see if I can port it.

I tested the solution which you’ve provided, however the second ethernet port still doesn’t get brought up. You mentioned that you’ve also modified the driver, however per the commits, I did not see any changes to the driver, except to the dts. Is there an additional step which must be taken in order for the second ethernet port to be brought up? Thanks in advance!

I confirm, this patch doesn’t work

I tried your approach. Second ethernet port still not available. Do you have some uncommitted changes?

It won’t work until Realtek/SinoVoip releases HwNAT drivers for Linux kernel.

When will this be happening I bought this W2 board months ago thinging I could use it straight away only to find both Ethernet Ports do not work. I bought the M3’s thinking I could boot from SATA when in the end I found out you could not do so. I bought 2 R2’s and found out they will only transfer at 10Mb/s. Why dont you test your hardware before selling it this is really bad practice and is going to get you a very bad name. We never ever would think of doing something like this when we were in production. ALSO can you please release all sources for Debian, Ubuntu, and Fedora, under the GNU License as is required upon asking !