Banana Pi BPI-W2 new image: Android 7.1.1 support GMS 2019-01-14

BPI-W2 Android7 new image support GMS 20190114


  1. How to burn Android7 image on W2 Emmc by bpi-copy.

    (1) Download Linux image from here:

    baidu drive:

    google drive:

    (2) Burn this ubuntu image on your sd card.

    (3) Sw4 switch to 1, then use W2 boot from this sd card which you have burn ubuntu image.

    (4) Then “cd /”, you will find an Android7 image in this directory.


    (5) Use “bpi-copy” to burn image to emmc.

    (6) Then power off W2, switch Sw4 to 0, power on.

  2. How to update android image on W2:

    (1) Download new android 7 image from here:

    baidu drive:

    google drive:

    (2) Copy the file “install.img”, to your usb disk.

    (3) Plug your usb disk in usb3.0 interface of W2.

    (4) Use usb-serial to connect W2, open a console terminal on your PC.

    (5) Then power on W2, and press “Tab” button on PC to update image in your W2.



Does this firmware support include Bluetooth drivers with RTL8822BE。

yes, it should work, here is my device bt picture:



did you connect debug console?

when you open bt, what does it print?

1 Like

My BPI-W2 brushes a LAN port after Android 7.1.1, RTL8822BE Bluetooth function, audio out, two SATA ports (plugged in Intel DC 3710 400G solid-state hard disk) can not work properly. USB3.0 mounts 2.5 inch 4T mechanical hard disk, data indicator flashes, unable to display storage devices.

I don’t why your device is not work, did you have qq or skype? we could talk this by private.

My QQ is 372536862.Think you!

how to burn this ubuntu image on a sd card???

Hello, you could use “bpi-copy /dev/sd to install image” on your sd card.

Hi, my purpose is to have a BPI-W2 running OpenWRT as the router and on top the Android as a media center.

I got the BPI-W2 stock board (which have both OpenWRT and Android) but the router function was incomplete (Kernal 4.1).

Then I followed the instructions to upgrade the OpenWRT with Kernal 4.4 %E5%9B%BE%E7%89%87

Which is finally working now. Have the router able to connect to WAN and routing to my PC via the LAN port. Console is good. SSH to the router is good.

However, the Android disappeared and now I have to install the Android back. I follow the instructions here. %E5%9B%BE%E7%89%87

Downloaded the image “”, unzip and copy the install.img into root directory of a U-disk, copied the essential 4 files to the root directory of U-disk as well.

And do the following in the recovery console as instructed: Realtek> usb start Realtek> fatload usb 0:1 0x01b00000 Realtek> fatload usb 0:1 0x03000000 emmc.uImage Realtek> fatload usb 0:1 0x02100000 rescue.emmc.dtb Realtek> fatload usb 0:1 0x02200000 rescue.root.emmc.cpio.gz_pad.img

All comes out without error until:

Realtek> boot all

Which said, “no this command”

And Android seems still not there (can only verify from HDMI output a blank screen).

So what’s been wrong with the steps?

P.S. I tried different ways of creating SD card images but even more errors on BPI-copy so I gave up the SD approach…

I have running Ubuntu on my SD so I did similar to this guide but a bit different.

  • Downloaded full Ubuntu image as in step 1.
  • Extracted Android image from it.
  • Pushed whole to my running Ubuntu over network (SCP from Linux laptop)
  • Ssh to Ubuntu on w2
  • Updated bpi-tools on w2 board
  • Run bpi-copy command as in step 5

Shutdown bpi-w2, sw4 to 0, boot to Android just fine.

From my perspective it looks like either you have outdated bpi-tools installed on your bpi or downloaded corrupted image.


FIrst, I am not going to use Android + Ubunto. I want to use Android + OpenWRT which gives me the router function (which I already upgrade the OpenWRT to a version with Kernal 4.4, since the stock one with Kernal 4.1 is a NON-functioning OpenWRT.)

Secondly, I finally could create an image of Android 7 into a SD card from here: %E5%9B%BE%E7%89%87 with the image file “”

I boot from this SD image (SW4 = 0), Andriod appears on screen. But when I check the OpenWRT by clicking into menus from Android, it comes back to the old “Kernel 4.1 OpenWRT”! That is, I suspect this version of “Android Image” comes with the old NON-functioning OpenWRT. If I write this image (which is a 8GByte full image) to the EMMC, I will just come back the point ZERO without a good router.

So I think I need to go for the second method as described in top of this post, just to install the Android part from the file “” (an image of around 8MBytes), without touching the GOOD OpenWRT which I upgraded. I suppose I just to load only 5 files to the FAT, as by below instructions.



However, I as said I got error when executing the final command of “boot all” and the android did not come out as expected.

Could SINOVOIP FAE provide a complete, detail step-by-step instructions on:

  1. How to upgrade the OpenWRT (with latest image)

  2. With the upgraded OpenWRT untouched, how to install the Android (with latest image) to another partition, then how to update the necessary U-boot (with image) so that the system will boot from the Android not the OpenWRT?

No one from SINOVOIP can provide a solution???