Banana Pi BPI-R2 OPENWRT 19.07 Image

Hi, I have a banana pi r2 device, but I cannot install up-to-date 19.07 openwrt software. Could you please share if you have stable working software? The device does not work when I compile it myself.

Banana Pi R2 support has been added to OpenWRT trunk recently so you need to compile the master branch. The changes were not merged into 19.07 yet.

P.S. There is no support yet for the internal WiFi so you need to use and external mini PCIE WiFi card. Also HDMI support was not added.

1 Like

Openwrt will not add this driver because it is too big and dirty…but maybe you can add it?

I compiled myself, I also tried the snapshot version. in both, the device was not turned on. I install the tar.gz file with the balena etcher on the microsd card. Is there anything else I need to do? where am i making a mistake? I will only use it as a cable router. internal wifi is not important to me.

Have you booted it before? You know that you have to press on button at least 10 seconds?

yes, I booted lede_Release_20180509 smoothly with balena etcher. but the last snapshot version is not booted. I select the file “bpi_bananapi-r2-squashfs-img.gz” with balenaetcher and install it to the memory card. I hold the power button of the device for 20 seconds. The device lights off as soon as I stop pressing the button. I think it feels like there is a u-boot problem. What can I do for it?

imho you need to setup debug-uart (usb2serial adapter) to see whats happening and on which state it hangs

now I have plugged in and tried the serial cable. Nothing happens in the teraterm application. black screen only. lede_Release_20180509 runs smoothly and I can trade via teraterm.

I loaded it with balenaetcher like this.

if no output gets shown, then the first bootheaders may be missing (SDBOOT,BRLYT,Preloader)…preloader makes first output on serial

maybe you have flashed the wrong image? you can take a look at the image/sdcard with an hex-editor if the bootheaders are there

  • offset 0x0: SD_BOOT
  • offset 0x200: BRLYT
  • offset 0x800: preloader

preloader is missing.

I have emmc_boot instead of sd_boot.

which one have you burned to sdcard? first is uboot-environment and second is emmc-image

I downloaded it from the link here. I extracted the compressed file. I changed the file name to mtk-bpi-r2-SD.img. I installed it on the sd card with the command “sudo dd if = mtk-bpi-r2-SD.img of = / dev / mmcblk0”.

which image have you downloaded? only the first can work…the other both are for emmc

I downloaded bpi_bananapi-r2-squashfs-img.gz file.

The bpi_bananapi-r2-squashfs-img.gz image will boot if you write it to an SD card.

To boot from eMMC it also works (despite saying SDMMC_BOOT at the start) because the important part which needs to says EMMC_BOOT is in the boot partition /dev/mmcblk0boot0.

To install manually you need not only to write the image to the main user area of the eMMC as you did, but also write the eMMCboot.bin file (from the FAT boot partition /dev/mmcblk0p2) to the eMMC boot region.

If you boot from SD there is an option in the U-Boot menu to install it to eMMC, which should set up the boot partition for you. Please let me know if it doesn’t work for you.

Hi, I applied what you said and failed again. I write the commands I tried below: (I named the file I downloaded as “mtk-bpi-r2-EMMC.img”)

dd if=mtk-bpi-r2-EMMC.img of=/dev/mmcblk0
echo 0 > /sys/block/mmcblk0boot0/force_ro
dd if=mtk-bpi-r2-EMMC.img of=/dev/mmcblk0boot0
dd if=eMMCboot.bin of=/dev/mmcblk0p2

partitions like this. but not starting.

can you prepare a guide from the beginning? I don’t know much. thanks a lot :slight_smile:

echo 0 > /sys/block/mmcblk0boot0/force_ro
dd if=eMMCboot.bin of=/dev/mmcblk0boot0

You’ll also want to fix the contents of /dev/mmcblk0p2 now you overwrote them.