Banana pi BPI-M3 new image:Ubuntu-16.04-mate-desktop-beta-bpi-m3-ov8865-sd-emmc-2017-07-13

this image support HDMI display

  1. based on ubuntu 16.04.2 LTS Mate Desktop
  2. support BPI-M3 kernel 3.4
  3. username & password: pi/bananapi , root/bananapi
  4. support LCD 7"
  5. support LCD 5"
  6. support HDMI 1080P & 480P & 720P (default)
  7. support GMAC
  8. support WIFI
  9. support BT (with bluetoothctl can setup)
  10. support SATA
  11. support UART
  12. support I2C
  13. support eMMC (support boot from eMMC)
  14. support IR (getevent can test)
  15. support touch screen (can control desktop or getevent to test) 15 support power key (getevent can test)
  16. support OTG & adbd (default off)
  17. support CAMERA ov8865/ov5640 (guvcview / cap / ffmpeg-3.2.1 support video H.264 hw encode, default use ov8865)
  18. support uEnv.txt to fatload uImage
  19. support bpi-bootsel to set LCD7" / LCD5" / HDMI (720P & 1080P & 480P)
  20. support bpi-copy to write SD/eMMC with file
  21. support video play 1080p with vdpau (mpv)
  22. support wiringpi 2.44 (, thanks to &
  23. support rpi.gpio 0.6.3 for python (, thanks to
  24. Thanks for linux-sunxi community (
  25. Special thanks for Alex support with camera functions (

Google Drive:

baidu cloud:

MD5: c37b4529d247e53799af4ca274d0805d

FILESIZE: 1654438821 (~1577MB) UNPACK: 7456MB (eMMC size)

How can I change from ov8865 to ov5640?

it also support OV5640 camera .

How can i change standard hdmi resolution, because i tried modify uEnv and nothing changed

Apparently the changes that are made to uEnv.txt do not work, at least to me it does not work for me. How could this problem be solved?

Unfortunately I do not even have to change the HDMI resolution! 720 -> 1080?

I see this has “OTG & adbd (default off)”. How do I enable this? I’m trying to use this thing as a mass storage device.

How do I rotate a 5 "lcd?

What about standard resolution 1024x768 or 1280x1024 ?

Hy all, did you have any issue with the BT because mine is always crashing…

does it support hidraw? so we can make user mode drivers.

Finally works partial. For FULLHD you should use the command bpi-copy. I was happy that finally usb-audio works. But… After an update, Firefox is not working anymore. In Chromium “hardware acceleration” is not works. MPV only works with mkv and mp4 videos. Modification of uEnv.txt is ineffective. I’ve had this computer for a year, but now it’s enough. Unfortunately I have to say that this computer is not suitable for mediaplayer. I will sell it. My son also has a Raspberry Pi M3, which is slower but everything just works …

I can’t change the resolution to 1080P in the Display settings. sensors-detect doesn’t showing any sesnors. Mozilla doesn’t work after apt-get upgrade How to burn this image straight to eMMC?

can not compile Pangolin successfully.

ld report:

/usr/bin/ld: CMakeFiles///SimplePlot.dir/usr/bin/ld: usr/bin/ld: CMakeFiles/main.cpp.o: undefined /CMakeFiles/HelloPangolin.dir/main.cpp.o: reference to symbol 'usr/bin/ld: SimpleVideo.dir/undefined reference to symbol '[email protected]@GLIBC_2.4'
//lib/[email protected]@CMakeFiles/main.cpp.o: gnueabihf/ error adding symbols: DSO missing from command line
//lib/arm-linux-SimpleDisplayImage.dir/undefined reference to gnueabihf/main.cpp.o: undefined symbol ' error adding symbols: DSO missing from reference to symbol '[email protected]@command line
[email protected]@GLIBC_2.4'
/collect2: error: ld returned 1 exit status
//lib/arm-linux-gnueabihf/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
collect2: error: ld returned 1 exit status
/lib/arm-linux-gnueabihf/ error adding symbols: DSO missing from command line
/usr/bin/ld: CMakeFiles/SimpleMultiDisplay.dir/main.cpp.o: undefined reference to symbol '[email protected]@GLIBC_2.4'
//lib/arm-linux-gnueabihf/ error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
collect2: error: ld returned 1 exit status

and it seems libpng has duplicated lib and libc also.

to see this problem: sudo apt install libglew-dev git clone cd Pangolin mkdir build cd build cmake-gui … remove realsense build option cmake --build .

tested almost all images for m3, only 2017-10-23-ubuntu-16.04-server-preview2-bpi-m3-sd-emmc.img could work.

But when compiling opencv, there were compiler seg faults occasionally. google this problem, it said that with hardware problem?

/usr/include/c++/5/bits/vector.tcc:535:5: internal compiler error: Segmentation fault } ^ Please submit a full bug report,

Hi Friends, when i connect the HDMI with monitor , only show log ( bpi ) then device off automatically. what can i do?. pls help me guys.

please check your SD card ,and try again , it is image not work .

Hi zhu

Dd you manage to resolve this issue?

I’m facing the same issue, albeit with a different compilation target, with the specific message as follows::

g++ -ggdb -o “lkdemo” “lkdemo.cpp” pkg-config --libs --cflags opencv (in directory: /home/pi/projects) /usr/bin/ld: /tmp/ccwJo4Gi.o: undefined reference to symbol ‘[email protected]@GLIBC_2.4’ //lib/arm-linux-gnueabihf/ error adding symbols: DSO missing from command line collect2: error: ld returned 1 exit status Compilation failed.

I have a hunch that there is a duplicate library of another version in my path somewhere causing this…

The keyboard and mouse do not work. The same power supply was working on the x86 desktop

How can i get touch working? I use this display from aliexpress: aliexprees-url. I installed ubuntu-16.04-mate-desktop-beta-bpi-m3-lcd7-ov8865-sd-emmc.img-2017-7-13 image and updated everything. Display works but touch isn’t working getevent give me this error:

[email protected]:~# getevent
add device 1: /dev/input/event4
  name:     "sunxi-ir"
could not open /dev/input/by-path, Is a directory
add device 2: /dev/input/event3
  name:     "sunxi-ths"
add device 3: /dev/input/event2
  name:     "headset"
add device 4: /dev/input/event1
  name:     "sunxi-keyboard"
add device 5: /dev/input/event0
  name:     "axp81x-supplyer"
could not get driver version for /dev/input/mice, Not a tty