Banana Pi BPI-M3 New Image (New EMMC) Release: Raspbian jessie 8.0 2018-5-28 V1.1


1.Is the SATA driver in the kernel so I can put Raspbian on SSD but still boot from SDCard ?

We built in SATA driver,but I didn’t try this like you said,you could have a try.

2.Booting okay but eth0 not initializing on startup.

Did you connect RJ45?

3.wlan0 - does not seem to be working either.

you need config your wpa_supplicant.conf, to start up wlan0, see WiFi Client from our wiki:


  1. Okay will be checking SATA configuration tomorrow hopefully.
  2. You guessed it RJ45 problem :slight_smile: But I had to write a new SD Card to get it to work. Once the image is upset it will not reconfigure by itself. ifconfig was showing the connection was up but ping was not seeing the router !
  3. Okay I will look into this tomorrow.

Done an apt-get update and Chrome still okay ! And apache2 installed and running !

Cheers !

1 Like

@Jackzeng Do you think it would be possible to make Docker works under bpi-m3?

we have test docker works on BPI-M3,

1 Like

@baskwo - Depending on what you are doing you would probably want SATA drive working first in order to run docker.

@jackzeng I still have not checkout running and booting from SATA as I got distracted by other tasks unfortunately, but WILL do ASAP.

But I have just got your Jessie distro upgraded to Stretch !

@sinovoip - will the existing eMMC boot from vfat on SATA as it is or would that require updating eMMC ? If not would it be possible to add it as a default to boot from say SDCard and if not then from SATA vfat ?

Cool,Aaron; I can do a test today,Lets check if M3 could boot from SATA.

1 Like

@Jackzeng - I am just closing down for the day as its late I am in the UK.

I have mounted SATA using /etc/fstab before but booted (debian) using SDCard for uEnv.txt and uImage and associated *.fex and misc files.

I did the same on the M3

1 Like

thanks for your information,I will check it later.

@Jackzeng - I did get builds of bpi-build and armbian Stretch built under docker on my i7 machine. I still cannot find a build for Raspbian though if you have a link I would well appreciate it.

If you want we can work closely together I can follow up what you have done reproducing it and doing docker builds and accompanying documentation on how to do the builds.

Also another issue on the M3 is the PowerVR GPU support. At the moment it does not seem to use GPU. The tell tail window drags and shake gives it away.

I though I found source code some time ago for the PowerVR SGX544MP1 but it does seem to be propitiatory though ?

@sinovoip - I think one of your Ubuntu builds had PowerVR support as the window drag and shake test showed it had support.

This looks like the .deb file for it possibly :-

Thank you,we are building our new wiki recently,

I would like to hear you can join us to complete it,if you have interest.

For building image, You can have a look in here:

but if you use original image, you need to change something, I have no idea if our team will put a build on github, but be positive.

M3 could use opengl es 2.0 to support GPU, powerVR gpu I have no idea, but we can try to support it in recent image.

1 Like

@Jackzeng - Ah your not building Raspbian from source then. I tried to find out how to do this but there does not seem to be any repo or instructions anywhere on the web.

I am going to probably go down the Armbian route then in the medium term. I need something working to act as a Node.js web server in the shorter term though so will stick with working with you on this.

I will put up the instructions and hopefully an image as well for the Stretch upgrade tomorrow.

okay moving to SATA is very easy, I over complicated it at first due to my past implementation without the SATA module being in the kernel.

Instructions :-

  1. Attach SATA drive and power to BPI

  2. bootup

  3. run ‘fdisk /sda’ and create three partitions :-

    • sda1 a 100MB vfat partition
    • sda2 an ext4 partition of the main paritition the bulk of the disk
    • sda3 a 8 or 16 GB swap partition
  4. mount the SSD

    mkdir /mnt/sda2

    mount /dev/sda2 /mnt/sda2

  5. copy main directories from SDCard ext4 root


    sudo chmod u+x

    sudo ./

  6. modify or copy /etc/fstab file system table from

  7. reboot !

And hopefully you should now have a functioning Raspbian running on the SSD but still booting from the µSD Card.

In order to boot from SSD the eMMC uEnv.txt needs modifying … Ideally we modify it to check the µSD Card first then if thats not inserted or bootable with a VFAT partition it should boot from the SSD’s VFAT sda1 partition.

@sinovoip - if you could chip in on this I would be grateful as I have not fully got my head around uBoot uEnv.txt scripts as I have not been able to find any documentation for it and the source code is next to impenetrable.

@Jackzeng - when this procedure is tested we can add it to the wiki

1 Like

I will write up the Stretch upgrade tomorrow as I want to do it again to verify my written instructions from last time are correct. There are a few points where you have to make decisions in the main upgrade step regarding file update decisions that I want to verify.

I was mistaken this is not working you cannot mount / in /etc/fstab :frowning:

Still no wlan x-(…

Do you mean wireless card? Actually this image have wlan0,and support WiFi STA mode.

Did you try “ifconfig -a”?

Pls can someone give a tutorial to run DS18b20 temperature sensor on this image.


I,ve installed raspbian image in my bpi-m3 and volume control doesn’t work. The master of the speaker always stays at zero and i can’t change it. I’ve searched for solutions in different forums without success.

I’ve try different comands in console like amixer sset Master 100% amixer cset numid=1 – 100% > /dev/null amixer cset numid=3 2 trying to switch the audio output to HDMI … and none of the solutions has solved the problem.

Could someone guide me to solve the problem? Thanks.

I am new to the banana Pi but I got a few raspberry. I have downloaded this image but it just won’t boot and the red light shows. Is it because I am not flashing it to the EMMC? I just “dd” it on a SD card. Please help, I am just using the no jessie build that have no Wifi support…

Now even the links to download the latest image are lost… It is so poor of the software support even banana pi got better specification. I can only use a test machine… so disappointed

Hi! alright? We use raspberry pi 3 and 4 as a local server, (Raspberry Pi 3 models B and B+ and also raspberry Pi 4). But here in Brazil it was very expensive and difficult to find these models. I tried to start the SD card with the Raspberry direct image on the Banana Pi M3 but it didn’t load. Can anyone help me with this? Any idea?