Banana pi BPI-M3 android 5.1.1 image update

BPI-M3 android 5.1.1 image download link:

1,android version : 5.1.1 2, support double-screen display, MIPI Display and HDMI display. 3, support 720P and 1080P 4, wifi working fine. 5, 1000M RJ45 working fine. 6, emmc working fine. 7 , USB and OTG working fine.

Ok, next try. There’s an Android image. But there are no instructions what to do with it. If you write it the usual way on an SD-card then the image won’t boot. Great user experience, @sinovoip, just as usual.

Why is @sinovoip not able to point out that you would need PhoenixCard to burn this image to an SD-card?

Since this image should run on a M3… where are the instructions how to get this image in eMMC?

WiFi work not fine…

opened wifi and scan wifi is nothing

Thank you. This Android image definitely usable, but there are some minor nits:

  1. The screen image are slightly wider and higher than required;
  2. HDD connected to the SATA ports mounts and reads just fine, but ES file explorer can’t write to to it and complaining about insufficient permissions;
  3. NFS mounts do not work, probably due to the missing kernel module;
  4. Kodi freezes when playing 1080i video, this doesn’t look like video hardware issue;
  5. I2S module seems missing as well.

But in general, I’m impressed by performance of A83t and looking forward for stable release.

1113, WIFI works, but with on-board antenna it have very low sensitivity.

My M3 is very sensitive with power. Since I am using HDMI, USB mouse and Keyboard, my M3 reboots sometimes. I think this is power issue. Without USB connected, things are fine…

Another BPI-M3 issue… ahhhhhhhhhhhhhhhhhhhhh

I have zero USB devices plugged in and soldered on new pins for power supply hook up and it still reboots on me :frowning:

check your HDMI cable if possible… I had similar issues. What I did was disconnecting HDMI while booting and connecting the HDMI cable afterward. I am not really sure if this made it work or it was some soft of voodoo, but I am able to boot now. Also, check other images of Android for M3. I think its previous version will work fine.

Good luck!

I hope BPI-M3 becomes stable with Android and Linux very soon.

Sadly, I’ve tried a bunch of cables.

In my other post, I ended up reflashing the eMMC a few times… and it finally booted again. Up until point i setup WIFI and it junked out again and won’t boot until I reflash it a few times.

Can not for life of me get it to boot of any microSD card. And only thing that will flash to the eMMC is the Android image.

I am not an expert in this department at all. Actually, I am not an expert in anything. However, I think eMMC boot sector and SDCard boot sector requirements are somewhat different. Perhaps, that’s why you cannot boot from SDCard with eMMC image.

I really hope SINOVOIP comes up with something stable instead of waiting for everyone to work on things. I don’t mind being a beta tester for images, but I am pretty sure developers don’t want to develop for a hardware released by SINOVOIP without any support.

Where are the instructions how to burn the image??

PhoenixCard & Phoenix/LIveSuit: I have tried on Windows XP 32bit and lubuntu 14.04 LTS x86_64, no way worked out. Only red LED is on, device should be in debug mode, as it didnt boot from the SD card. @ Lubuntu with LiveSuit, I get: Failed to flash firmware: Get device stage failed

It is a shame that you don’t burn at least the android image to the eMMC in the factory.

How shall a new and beginner-level customer test the hardware? I’d say many people will send the board back and get refunded, because they think its broken. It is not so EASY as you always say.

@ WinXP with PhoenixCard, I get something like: card preprocessing failed, error code !1251. Heck, whats wrong??

The card is 8Gb and worked in my cell phone. I have no clue why they don’t test their procedures and publish recommened configurations, reminds me of a garage company from the seventies, they still sell their apples because they have improved so much over the years. Other companies just vanish, because they don’t improve…

TODO: Obsolete: Ok, I’ll get a newer SD card and try again with PhoenixCard 3.1.0 and PhoenixSuit for eMMC

Hello again, I am writing this from Android on BPI M3:

I finally managed to flash Android directly to eMMC

(which was my goal to have a quickly booting OS just for internet browsing) using LiveSuit on Lubuntu 14.04 LTS following the steps from: That is, I cloned the software from github, build it and followed the other steps regarding the kernel module. My hint is not to rely on downloaded deb packages, but to build the stuff individually on your linux OS. For stable WIFI, I bought an antenna, see Ubuntu Mate 15.10 image thread:

Video is better than in Ubuntu, sound from headphone jack works out of the box.

Wifi doesn’t work for me either.

I’ve just tried the image and it works like a charm :slight_smile: But there is one thing I don"t understand. Isn’t there Google play store app installed? How can I install any app?

Where can I download the android 5.1 SDK instead of binary image? Like this url for A64

Thank you for Image. I have one Problem.

  • Amazon Video Crash. Then the hole Banana PI M3 hanging.

I have 2 Power-Connections with 2,4A and 5V.

Where can I finde the Logs?

EDIT: SKY GO works without crash/haning. I Think software issu.

EDIT2: An old Amazon Video APP (Version: (57030110) works.

But the board might only get 1.8A and 4.6V:

Very Bad. Can I stop Cores or fix it to 1,6GHZ under Android?

EDIT: The old Version of Amazon Crash too. Sometimes i hate the Board. EDIT2: cooling with a Fan & remove all USB-Hareware don’t work. The Board freezed at the amazon-App

…will increase stability problems since then the board throttles later and undervoltage occurs earlier. Get a multimeter and check the voltage available when some load is on the board:

And no you can’t fix hardware errors with software.

The Board freezed only by Amazoin Video. Kodi and Sky Go works.

So what? Use a multimeter and check voltage available. Undervoltage only occurs with high load. Maybe Amazon video causes more load. Don’t know, don’t care. The M3 has the wrong DC-IN connector therefore it’s a no-go anyway :slight_smile: