Access uboot command line on BPI-M5

I’m trying to clear my linux image from the eMMC of my Banana Pi M5, and based on the wiki, I have to access the uboot command line to do that.

I connected an usb-to-serial adapter and I can see the boot messages, but I’m not able to stop the boot process and enter the uboot command line. I’ve tried pressing the ESC and other keys, but nothing worked.

What is the issue? How can I stop the boot process and enter the uboot command line?

Or any other alternative for erasing the eMMC?

make sure your usb serial tx work, Enter, Space or Ctrl+C can stop and enter command line

Hit Enter or space or Ctrl+C key to stop autoboot -- :  0 

If your emmc linux can bootup, another way is erase it with dd command in linux.

Ah great, this worked and I was able to get into uboot.

However, for some reason using the mmc command wants to operate on the SD card by default instead on the eMMC:

    => mmc info
    Card did not respond to voltage select! : -110
    => mmc list
    sd@ffe05000: 0
    mmc@ffe07000: 1

How can I use the mmc command on the eMMC to clear it?

(Note: it might be that I actually managed to clear the eMMC by inserting a bootable USB, pressing the SW4 switch on power on and removing the USB during boot (I read somewhere that it causes the eMMC to erase). Could that be the reason why it want’s to default to the SD card?)