A little help please (no boot)

Hi guys. My R2 just arrived. I was not sure how to layout the partitions etc, so I just downloaded the latest ubuntu image and followed the quick start guide. I figured I’d investigate from there after booting up.

Trouble is its not working. Before prepping the SD card, I had tried to power on the device just to see if I could get a uboot console or anything. I have wired up the debug uart and am using screen “screen -T screen-256color /dev/ttyUSB0 115200,-crtscts” this works fine for my old guruplug. I don’t see anything on the serial console. When pressing the power switch the red, green, and blue LEDs light. They will stay lit if I hold the power switch. If I momentarily touch the power they go out as soon as the switch is released.

I read some posts here that suggested it might not power on without an SD card present, so I prepared on as directed. I still get the same behavior. Just for fun I plugged in an HDMI monitor and keyboard, pressed the button and simply waited in case ubuntu would boot. Nothing.

I am using a good quality power supply rated a 2a 12v. I put a string a lights on it and checked with my VOM there was no measurable voltage drop; so I am confident it works.

Am I missing something? Is this a bad board?


You’ll have to press powerbutton 10 seconds. the r2 will only boot if at least preloader and uboot are on sd/emmc (that should be the case for ubuntu). The early boot is only visible on debug-uart (how is your wiring? Which adapter-chipset?). official uboot is set to 720p (your monitor must support it) and seem to work not with all displays.

Thanks for very fast reply! I feel pretty dumb now. I guess I just never held the power button long enough. Tried it again counting to 10 and it boots right up. Thanks!

I have same issue and did all the steps that OP did. However even after 10 seconds it does not boot. It there some sort of diagnostic that can be run on the board. The only thing that I have able to do is to press the power button and the LED’s labeled as RGB turn on.

You have burned a image (which one) to sdcard (direct not to a partition)?

The only way to see anything in early boot state is the debug-uart (usb2serial-adapter connected to debug-pins with putty/minicom)

if the RGB LEDs come on that would tend to indicate the system is running.

If you are not seeing any output are you sure your UART interface is good. You may already realize but its not rs232 its lower voltage logic. If you are using like a “USB-to-serial” adapter like the type you would connect a modem to that won’t work.

Note that hdmi only works with kernel 4.4 with resolution 720p on some displays

It seems that I as not able to format the card correctly using the Linux commands. It has some partition (Was using it with an odroid board). I used my windows PC and then everything seems to work OK.

HDMI worked well. I have a Lenovo 21.5" monitor and it did not have any issues.

Thanks for your help.


Why format?

dd if=img of=/dev/sdx

No number after sdx!

I had formatted because the instructions said so. However, I am finally up and running. Now need to work on getting the gcc working!