BPI-M2 Zero Armbian 5.41 3.4.113 (Debian Jessie, Ubuntu Xenial)


#1

Older images keep breaking on me if i try to update, due to changes in the dt-file i think. So i build my own, maybe somebody else will get some use out of it.

Debian Jessie http://www.mediafire.com/file/rd58jqjp1vyx61e/Armbian_5.41_Bananapim2zero_Debian_jessie_default_3.4.113.img.zip

Ubuntu Xenial http://www.mediafire.com/file/lblc0l0c41c3cj8/Armbian_5.41_Bananapim2zero_Ubuntu_xenial_default_3.4.113_desktop.img.zip

I build both images with default config and patches for M2 zero. As I just needed a recent image for some quick testing I did not change anything.


BPI-M2 Zero + Camera + Armbian support?
HDMI BPI-Zero Not Working
(bpi team) #2

very cool ,thank you share this image.


#3

For me it works ok. The only problem is the display configuration, possible only by the command h3disp. Is it possible change by setting menu?


(Aaron Gray) #4

Hi g33k,

Do you have source for the creating the boot FAT image I have been trying to do this but have not had time to complete it. If you could share it on ideally on GitHub or post or send me some instructions - aaronngray@gmail.com

Thanks,

Aaron


#5

@ronfa I only ran it in a headless setup, but since the patches for M2 zero are applied i would expect to work out of the box or by using armbian-config.

@AaronNGray

Check out compile.sh for how its done. https://docs.armbian.com/Developer-Guide_Build-Preparation/


(Aaron Gray) #6

@g33k - I tried the M2 with 8-core mod Armbian build a while back but it did not produce a VFAT partition only the EXT3 one in the image.


#7

Now I see where you are coming from. I am not able to check right now, but I guess it’s ext4 which uboot is able to read. No need for vfat partition.