LCD touch, need driver? Or it's broken?


(Adrian Dudziak) #1

Hello. I have a problem with new LCD S070WV20-CT16 and BPI-M2. I have S070SWV20HG-DC16 and it works fine, but now i have that new one. Picture looks fine, but touch screen doesn’t work. I need some driver or what? System is Ubuntu. Thank you for answer.


(bpi team) #2

need update new driver. we do it now .


(Adrian Dudziak) #3

Hello. So how can i install driver on old system now? Is it possibe or i need reinstall?


(Ronald Becerra) #4

Hi.

I have the same issue. I have connected a LCD S070WV20-CT16 to a M64 board and installed an ubuntu image, however touch is not working. Where could I locate the updated driver?

Regards


(ZB) #5

Hello,

  1. For S070WV20xxxx Lcd screen to execute command “insmod /lib/modules/3.10.105-BPI-M64-Kernel/kernel/drivers/input/touchscreen/ft5x/ft5x_ts.ko” to enable Touch function.

  2. For HC070TGxxxxx Lcd screen to execute command “modprobe gt9xxnew_ts” to enable Touch function.


(ZB) #6

you need use new code to compile it, and update kernel.


(Ronald Becerra) #7

HI.

Thank you for the prompt response. I have installed an image of the following repository:

It contains an Ubuntu 16.04 LXDE image with kernel 3.10.105. It also contains the driver ft5x_ts.ko, however touch still not working. I looked at file /var/log/Xorg.0.log and there is no error but the touch is device is not being reconigzed. If I change driver to gt9xxf_ts in the xorg.conf, file /var/log/Xorg.0.log shows that the touch device seems to be regonizged, however still not workig.

Could you provide me an url of an image that Works with this device? Also, could you provide the URL where the driver can be downloaded from?

I appreciate your help.

Kind regards.


(ZB) #8

Hello, I will release M64 new Images tomorrow, please have a wait, thanks.


(Ronald Becerra) #9

Hi.

Thank you for your help!!!

Could you provide the link in order to download the image?

Kind regards.


(Ronald Becerra) #10

Sorry.

I was not checked the download links for M64 board, the new image is already there.

Thank you so much for your help!!!

Regards.


(Ronald Becerra) #11

Hi.

I was mistaken about the screen model, I got the HC070TGxxxxx, then I used gt9xxnew_ts driver. Touch was finally detected, however the touch seems to be not calibrated. I tried to calibrate it using xinput_calibrate, touch behavior improved however the right area and the bottom area are not being detected, checing the xinput properties for touch device I could see that the resolution or coordinates for the touch device were 1920x1200.

Could you help me providing a direction to solve this issue?

Thank you so much!!!

Regards.