Freezing, restarting, not stable


#1

Hi, I bought the BPi M3 + power adapter (5v - 2A). I cannot get it stable. Using a Samsung microSDXC EVO+ 64 GB 100MB/S CL 10 + Banana Pi BPI-M3 New Image (New EMMC) Release: Raspbian jessie 8.0 2018-5-28 V1.1 Plugged into a monitor through HDMI, added usb keyboard/mouse.

What happens when I start with the sdcard inserted:

Scenario 1:

  1. Banana Pi loading screen
  2. Linux loading screen
  3. Raspbian desktop screen
  4. Freezes after ± 3 minutes
  5. Sometimes it reboots, sometimes it shuts down.

Scenario 2:

  1. Banana Pi loading screen
  2. Linux loading screen
  3. After lots of hex codes, loading screen gets stuck with this message: https://drive.google.com/file/d/1FQM3ARZubRDocxViVPbtqQvA4i8M_Skt/view?usp=sharing
  4. Reboots/shuts down

Things I have tried:

  • Reformat sd card and prepared it again with newly downloaded image
  • Boot without usb equipment

Is there something else I am doing wrong or is this Pi just broken?


(Igor) #2

Try this (only) alternative if it works any better: https://dl.armbian.com/bananapim3

But my guess would be to check power supply. Replace it.


(ZB) #3

Yes, Did you use BananaPi’s power adapter?

and could you please show me the console log?


#4

Yes I used the BananaPi’s power adapter.

Where can I retrieve these logs when it freezes? Or should I just make a video out of this?


(ZB) #5

Hello, please see here, use usb to ttl

image

here is the debug console:

http://wiki.banana-pi.org/Getting_Started_with_M3#Prepare_to_develop

then please show me the debug console log.


#6

Ok, I ordered this cable. I will post feedback soon.


#7

Ok, I have this cable. I connected it to my Mac but how do read the debug console?


(ZB) #8

Do you have any terminal software on your PC?

plug your usb wire into your PC,and use the terminal software to open it,

I recommend you SecureCRT


#9

I did this but I cannot make a connection. I tried ‘screen’, Serial and in Terminal the connection does not appear under /dev/cu.usbserial. I have installed several PL2303 drivers for mac, but this does not work at all :frowning:

Which log file do you need? Can I find it when Raspbian has booted? Sometimes it boots, but the screen resolution is not good and the cursor is invisable. But I can use the console app when it booted (and I hope it does not get stuck).