BPI-R2 new image: BPI-R2 OpenWrt(LEDE) Souce code : 2018-05-09


(AB) #126

Yes

ap0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 02:08:22:14:22:47 brd ff:ff:ff:ff:ff:ff

(AB) #127

Thank you. I will check it out.


(Frank W.) #128

Then it seems to be hostapd which does not support the (standard) driver nl80211


(AB) #129

Can something else be used to start wifi?


(Frank W.) #130

imho not, but maybe you can replace your hostapd with hostapd-binaries from ubuntu/debian

https://packages.debian.org/us/jessie/armhf/hostapd/filelist

here you see depencies which you maybe need also (for armhf): https://packages.debian.org/us/jessie/hostapd


(ZB) #131

after you make menuconfig to choose nl80211, you will build the driver to image when you are compiling.

openwrt will download code, when compile.


#132

At this point i had continuously errors, guess server was not available for download. @nomadbeni i cannot testing until the TP-Link that i ordered arrived, cause bpi is now with alpinelinux my AP. @Jackzeng could you upload the sysupgrage somewhere else ? From Baidu i have always interrupts, its not possible to download from Europe… Thanks…


(ZB) #133

Hello , here is the google drive: https://drive.google.com/open?id=1UPDwVauZ59K5A83ydHH9x4gbeiq-nffi


(AB) #134

Thank you. I installed this, and managed to start wifi. I also installed LuCI and a new Wireless menu appeared. In it there are couple of radios and default wifi networks. I can search other wifi networks, but the access points that I enable from LuCI are not working. It says: Wireless is disabled or not associated

If I start the wifi using SSH it works, and when I close the SSH connection wifi still works. Also every time I start the wireles from SSH a new radio shows up in LuCI.


#135

Hi Jack. I create wifi with your command. And it work.

But for some reason i don’t know. All devices disconnect a few minute later.
And hostapd print this:

ap0: STA (private MAC address) WPA: sending 1/4 msg of 4-Way Handshake
ap0: STA (private MAC address) WPA: EAPOL-Key timeout
ap0: STA (private MAC address) WPA: sending 1/4 msg of 4-Way Handshake
ap0: STA (private MAC address) WPA: EAPOL-Key timeout
ap0: STA (private MAC address) WPA: sending 1/4 msg of 4-Way Handshake
ap0: STA (private MAC address) WPA: EAPOL-Key timeout
ap0: STA (private MAC address) WPA: sending 1/4 msg of 4-Way Handshake
ap0: STA (private MAC address) WPA: EAPOL-Key timeout
ap0: STA (private MAC address) WPA: PTKSTART: Retry limit 4 reached
ap0: STA (private MAC address) WPA: event 3 notification
ap0: STA (private MAC address) IEEE 802.1X: unauthorizing port
ap0: STA (private MAC address) MLME: MLME-DEAUTHENTICATE.indication((private MAC address), 2)
ap0: STA (private MAC address) MLME: MLME-DELETEKEYS.request((private MAC address))
ap0: STA (private MAC address) IEEE 802.11: disassociated
ap0: STA (private MAC address) WPA: event 2 notification
ap0: STA (private MAC address) IEEE 802.1X: unauthorizing port

What’s the problem? Could you help me?


(ZB) #136

Hello, I still don’t find the solution for this problem,but I find we can limit the speed to avoid this problem, here is my test command:


#137

Thx Jack.

BTW. On my devices, stateless Ipv6 doesn’t work. Do you have same problem?


(ZB) #138

Hello, Could you tell me how do you config stateless ipv6?

I use ipv6 ping other device , it works fine

image


#139

emm…

Our stateless ipv6 is config by an Ruijie S12010 switch.
Here is the config

ipv6 address (private Ipv6 address)::1/64
ipv6 enable
no ipv6 nd suppress-ra

So… I don’t know how it work. But other except R2.
I catch some packages and upload them in this topic
maybe it can help you


(SilverFox) #140

@Jackzeng I use your image, but I can’t start wifi:

root@LEDE:/mnt# cat hostapd.conf 
interface=ap0
bridge=br-lan
ssid=hw3
driver=nl80211
country_code=CN
hw_mode=g
channel=1
max_num_sta=5
wpa=2
auth_algs=1
rsn_pairwise=CCMP
wpa_key_mgmt=WPA-PSK
wpa_passphrase=xxyyzz
logger_stdout=-1
logger_stdout_level=2
root@LEDE:/mnt# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:08:22:00:04:FC  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@LEDE:/mnt# hostapd -d hostapd.conf 
Configuration file: hostapd.conf
'ine 4: invalid/unknown driver 'nl80211
'ine 6: unknown hw_mode 'g
'.ne 11: invalid cipher 'CCMP
'ine 12: invalid key_mgmt 'WPA-PSK
4 errors found in configuration file 'hostapd.conf'
Failed to set up interface with hostapd.conf
Failed to initialize interface
root@LEDE:/mnt# ifconfig ap0
ap0       Link encap:Ethernet  HWaddr 02:08:22:00:04:FC  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@LEDE:/mnt#

(ZB) #141

Hello, Did you try here?


(SilverFox) #142

I am using your sysupgrade image, and above problem is in your sysupgrade image.


(Frank W.) #143

looks strange…have your checked your filesystem?

Btw. @jackzeng is hnat working over br-lan?


(SilverFox) #144

how to check filesystem, there is no fsck command.


(ZB) #145

Hello,frank, I think hnat is probably not over br-lan.