BPI-R2 new image: BPI-R2 OpenWrt(LEDE) Souce code : 2018-05-09


#106

No you need emmc or sd because even if you compiled uboot with sata support your still need to load the proprietary preloader binary from either the sd or emmc.


(Frank W.) #107

right, preloader and uboot have to be loaded first, again from sd/emmc


#108

Hello all,

does someone succesfully added wifi with LEDE ?

Thanks in advance


#109

@frank-w maybe this can be the start script for wifi in LEDE ? Thanks to Alexander from the pandacor-Project

> depend() {
>         need localmount
>         after hwdrivers modules
>         provide net
> }
> 
> WIFI_DEV=/dev/wmtWifi
> 
> start() {
>         ebegin "Starting wifi firmware BPI"
>         eindent
> 
>         /usr/bin/wmt_loader
>         sleep 1
> 
>         /usr/bin/stp_uart_launcher -p /etc/firmware &
>         sleep 1
> 
>         if [ -e ${WIFI_DEV} ]; then
>             echo A >${WIFI_DEV}
>         fi
>         eoutdent
> 
>         return 0
> }
> 
> stop() {
>         ebegin "Stopping wifi firmware BPI"
>         echo 0 > ${WIFI_DEV}
> }

(Frank W.) #110

i don’t know lede…but it does the necessary things…

for comparision here is my script for debian/ubuntu: https://github.com/frank-w/BPI-R2-4.14/blob/4.14-main/utils/scripts/wifi.sh


(AB) #111

Hello

Did it work?

Thanks


#112

Sorry, I don’t tried. For now i ordered a TP-Link Router, because i am tired to try router-functions with BPI-R2. I will continue later building a NAS with BPI-R2…


(david s) #113

same here about to junk it, i am never buying any banana pi stuff, there is NO manufacture support, no progress from banana pi, all images are made by the community,


(ZB) #114

Hello,Do you mean Ap mode?

  1. Create ap0
  • wmt_loader &

  • stp_uart_launcher -p /etc/firmware &

  • echo A > /dev/wmtWifi &

  1. Create hostapd.conf
  1. Start Ap
  • hostapd -d hostapd.conf
  1. If your Ap is not stable, please limit the speed, here I limit download speed as 8Mbit/s, upload as 4Mbit/s
  • tc qdisc add dev ap0 root handle 1: htb default 11
  • tc class add dev ap0 parent 1:1 classid 1:2 htb rate 8Mbit ceil 4Mbit prio 2

(Frank W.) #115

hi jack,

is it possible to get the driver working without wmt-tools?

as far as i see the first command only sends a command to initialize, nothing more, at least this step can be done in a init-procedure that must be called automaticly. I don’t have the knowledge about drivers, but there must be such an function which every driver use for init.

second command is bit tricky…i have not figured out how it exactly works and where it is anchored in driver-code.

last step can stay outside (echo A/1) to change the mode (i also had not found this part in driver…i found where wmtwifi-device is created, but not where 0/1/A is processed)


(ZB) #116

Yes, it is complex,I was thinking to add these commands to /etc/init.d/xxx to initial ap when R2 is starting.

I could use /etc/init.d/xxx enable and /etc/init.d/xxx start to initial ap, but it fail to initial when R2 is booting. but I don’t know why it failed.

I will speed time to see the driver, probably we could make it easier


(AB) #117

Thank you! I tried this but it gives an error when I do step 3. invalid/unknown driver ‘nl80211’

How can I install that? I used the image from the 2nd link. The one with the hard-float.


(Frank W.) #118

i use a startup-script (on my github 4.14-main:utils/scripts) called by rc.local…this works so far, but i want to remove wmt-tools entirely and want the 2 first steps automaticly done by driver


(ZB) #119

Hi, frank, I got you, I will have a try to remove it. I tried rc.local, it works, but /etc/init.d/xxx could not.


(Frank W.) #120

Scripts in ini.d are needing a symlink in /etc/rc* created by update-rc.d but maybe this does not work with systemd


(ZB) #121

Could you show me the log? and I will check it later.


(AB) #122

Thank you. Here:

BusyBox v1.26.2 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
 /________/  LE  \  |____|___|___/|___|                      lede-project.org
 \        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (SNAPSHOT, r4772-5c84ada)
    \________\/    -----------------------------------------------------------

root@LEDE:~# wmt_loader &
root@LEDE:~# init combo device
Opened combo device
get device id : 30243
set device id : 30243
do module init: 30243
failed to init module 
stp_uart_launcher -p /etc/firmware &
[1]-  Done(255)                  wmt_loader
root@LEDE:~# open device node succeed.(Node:/dev/stpwmt, fd:3) 
chip id is 0x7623
chiId:0x7623, setting to property((null))
chiId:0x7623
run SOC chip flow
create pwr on thread ok
enter power on connsys flowpatch name pre-fix:ROMv2_lm_patch
fwVersion:0x8a00
/etc/firmware/ROMv2_lm_patch_1_0_hdr.bin
fw Ver in patch: 0x8a00
read patch info:0x22,0x00,0x06,0x00
gpatchnum = [2]
gdwonseq = [2]
/etc/firmware/ROMv2_lm_patch_1_1_hdr.bin
fw Ver in patch: 0x8a00
read patch info:0x21,0x00,0x0e,0xf0
gdwonseq = [1]
cmd(srh_patch) resp(ok)
root@LEDE:~# echo A > /dev/wmtWifi &
root@LEDE:~# nano hostapd.conf
[1]+  Done                       echo A 1>/dev/wmtWifi
root@LEDE:~# hostapd -d hostapd.conf
Configuration file: hostapd.conf
Line 4: invalid/unknown driver 'nl80211'
1 errors found in configuration file 'hostapd.conf'
Failed to set up interface with hostapd.conf
Failed to initialize interface

(Frank W.) #123

do you see ap0-device in when you call “ip a”?


#124

this was what i meant.


(ZB) #125

Hello, this is my .config, you can have a look, you can also use sysupgrade to update your openwrt. I have test it, enjoy it.