BPI-R2 new image: BPI-R2 OpenWrt(LEDE) Souce code : 2018-05-09


(Frank W.) #146

Then it also cannot work in lede where lanpprts are bridged. There is a br-section in prerouting. Here no tag is appended (wifi gets invalid) but in postrouting there are checks only for lan/wan

Can we make it work also with bridges and wifi?

@silverfox i do not know lede much,but there must be a tool for checking filesystem https://openwrt.org/docs/guide-user/storage/filesystems-and-partitions but i heard that package-install does not work correctly on some lede-images


(ZB) #147

yes, this is what I want to do, I will find time to support HNAT and Switch function on R2.

by the way, have you ever met this problem before?


(Frank W.) #148

Not till now,but i have only connected usb2-devices directly…i have no usb3-hub…

But you can try different kernel-versions and look if the problem happens on all. You’ll find kernel-versions 4.14,4.16,4.17 and 4.18 on my repo working so far on r2

My modified uboot allows booting different kernels (different filename)


(ZB) #149

Hello,frank,I tried kernel 4.14,it also has the same problem, usb3.0 is limited.

I think the next step is to check the code.


(Frank W.) #150

Can you try also 4.17(-main)/4.18(-rc) maybe its fixed in newer kernel


(ZB) #151

We found out the usb port of soc only support 32 endpoints, so is limited. I want to figure out how to change the endpoint.


(Frank W.) #152

usb-port of soc? i thought usb3 was connected via pcie

btw. do you use a powered usb-hub? is the problem also occour if no devices are connected to hub? maybe it’s a powering issue


(Maciek Szelągowski) #153

I have put first image from this post than tried to sysupgrade to your

(tried by webgui but I cannot get 192.168.1.1 by browser)

lede-mediatek-32-bananapi,bpi-r2-sysupgrade.tar

file and after reboot I have: can’t get kernel image!

enclosed log from upgrade

finally I would like to use that image:

https://downloads.openwrt.org/releases/18.06.0/targets/mediatek/mt7623/

but I don’t know how to install it to SD

log.txt (29,4 KB)


(ZB) #154

Hello,frank,I checked,I use 4 4G modules and they have their own power supply.

I changed code to decrease some useless EPs(endpoint), so I can support 4 4G modules now.


(ZB) #155

Hello, I saw your log, your boot could not load kernel because doesn’t support kernel format .

image

Images Link:

Google Drive: https://drive.google.com/open?id=1D6qPs73AXINarqFKFXuIMOr3-D6RmZAQ

Baidu Drive: https://pan.baidu.com/s/19Yu11pDFPa9UGdIdrQu3-A

This is my .config, you could use it built openwrt code.

CONFIG_ (152.5 KB)


(Maciek Szelągowski) #156

Thank you very much. Your image is working fine. Only the problem is when I want to install by opkg package ath10k for my pcie wlan card it needs kernel 4.14.xx. Can I just replace kernel 4.14.62 made by Frank-W? Or will you point me some other way to install ath10k drivers …

(great that other packages from official repo works)


(ZB) #157

if you could not use opkg, you could build these packages in your project by yourself, then install them to your image.


(SilverFox) #158

Hostapd is now running successfully, but this ssid is not found on both the phone and the computer. I don’t know why.

The terminal will output every ten minutes: ap0: WPA rekeying GTK

root@LEDE:~# cat /etc/hostapd/hostapd.conf
interface=ap0
bridge=br-lan
ssid=hw3
driver=nl80211
country_code=CN
hw_mode=g
channel=1
max_num_sta=9
wpa=2
auth_algs=1
rsn_pairwise=CCMP
wpa_key_mgmt=WPA-PSK
wpa_passphrase=xxyyzz
logger_stdout=-1
logger_stdout_level=2
root@LEDE:~# hostapd -d /etc/hostapd/hostapd.conf &
root@LEDE:~# Configuration file: /etc/hostapd/hostapd.conf
ap0: interface state UNINITIALIZED->COUNTRY_UPDATE
Using interface ap0 with hwaddr 02:08:22:04:56:13 and ssid "hw3"
ap0: interface state COUNTRY_UPDATE->ENABLED
ap0: AP-ENABLED
root@LEDE:~# dmesg|tail -n 3
[1087910.108733] device ap0 entered promiscuous mode
[1087910.113542] br-lan: port 5(ap0) entered blocking state
[1087910.118813] br-lan: port 5(ap0) entered forwarding state
root@LEDE:~#

(Frank W.) #159

Please drop bridge setting and try again


(SilverFox) #160

It’s okay after rebooting the system.


(SilverFox) #161

Why limit such a small bandwidth? The speed seems too slow.


(Frank W.) #162

It has nothing to do with bandwidth…wifi-chip seems to have problems with bridging


(ZB) #163

yes, because the ap mode is not stable,so I limit the speed to avoid the problem.


(SilverFox) #164

Where can I download the available tc packages? Opkg installation prompt kernel version does not match.

root@LEDE:~# opkg install tc
Installing tc (4.17.0-4) to root...
Downloading http://openwrt.proxy.ustclug.org/snapshots/packages/arm_cortex-a7_neon-vfpv4/base/tc_4.17.0-4_arm_cortex-a7_neon-vfpv4.ipk
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for tc:
 * 	kernel (= 4.14.42-1-71fb0e651a6aa044cd9eb86c91f17d9c) * 
 * opkg_install_cmd: Cannot install package tc.
root@LEDE:~#

(Maciek Szelągowski) #165

Can you please point me some instructions?