BPI-P2 Zero - WiFi issue


(Andreas Kalmbach) #1

Hi, I have some trouble with the new BPI-P2 Zero and its wifi. I have loaded your Ubuntu image (Ubuntu 16.04) to a SD card and booted the P2 zero. Booting works fine but I can not connect to any wifi network. The available wifi networks are found but after typing in the WPA password the attempt fails.

Do you have any suggestions?

Best regards, Andreas


(ZB) #2

Hello, May I know how did you config the wpa_supplicant.conf?

http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client

I did a test on my board, it should support.


(William) #3

Hi Jackzeng,

I also encountered the same problem.

My setting in wpa_supplicant.conf

network={ ssid=“AP-Name” psk=“12345678” }

Error massage:

Please help me. Thanks a lot.


(ZB) #4

hello,please type configurations like this:

image

then,please try again.

Your setting could be like this:

network={
ssid="AP-Name"
psk="12345678"
}

(William) #5

Hi ZB,

I have already confirmed, but the same failed.

nano /etc/wpa_supplicant/wpa_supplicant.conf

wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf


(ZB) #6

try “kill wpa_supplicant” and do “wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf” again.


(William) #7
Hi ZB,

I follow your suggest. execution succeed.

Step 1、nano /etc/wpa_supplicant/wpa_supplicant.conf`
network={
ssid="AP-Name"
psk="12345678"
}

Step 2、Check wpa_supplicant ID:
            ps -ef|grep "wpa_supplicant"

Step 3、kill -9 wpa_supplicant ID

Step 4、Run "wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf"

Step 5、Run "dhclient wlan0"

Success.  

Thanks a lot.