BPI-M3 new image:Kali-xfce-bpi-m3-sd-emmc.img 2016-5-12


(bpi team) #1

2016-05-12-kali-xfce-bpi-m3-sd-emmc.img.zip

  1. BPI-M3 kernel 3.4
  2. username & password: root/bananapi
  3. support HDMI 1080P & 720P(default)
  4. support eMMC
  5. support GMAC
  6. support WIFI
  7. support SATA
  8. support bpi-bootsel cmd can switch to (bpi-m3 & bpi-m2 & bpi-m2p)
  9. support uEnv.txt to fatload script.bin & uImage
  10. support uEnv.txt to set video 1080P & 720P & 480P …
  11. support power max. up to 2.5A ~ for DC-IN.
  12. fix rootmydevice issue

Google Drive:

https://drive.google.com/file/d/0B_YnvHgh2rwjRXg1bVpUbFFjb1U/view?usp=sharing

MD5: 024f033b00099800c909d0e4dd524721


#2

Is it really true? I cant believe it

Thany You so much :heart: :heart: :heart:


(bpi team) #3

hope you can help us do more test on this image.:slight_smile:


#4

I will try my best :smiley:

It would be great if you get the TP-Link TL-WN722N working for the BPI and Kali because Kali-Linux without a Wifi that supports Monitore-Mode is almost useless. But I’m sure you get this working.

Amazing job - Keep it up!


(Juhász Bence) #5

Can you make a Kali Linux image with 4.6 mainline kernel ? The new 4.6 kernel supports A83T SoC and a lot of USB WiFi adapters.


#6

Yes that would be great :smiley:


(bpi team) #7

yes ,when we finished 3.4 BPI kernel image ,we will plan to do this . we have boot mainline nernel success ,but need time to fixed some issue.


(Leszek Szpunar) #8

are you sure that this file is ok?

I tried to install by instruction: http://www.bananapi.com/index.php/download?layout=edit&id=42

but does not start. I still have the red light :frowning:


#9

Yes I have the same problem :frowning: Only a red LED and no boot or start… Hope you can fix this :wink:


(Leszek Szpunar) #10

Try to unzip Kali-Linux by 7z (http://www.7-zip.org/) .img - I have a problem with files inside .img. Ubuntu Image I can unzip without problems.


#11

I also have Problems to extract the File… Can you re-upload it or give us a tutorial how to extract it right please ?

I know it sounds stupid but I dont get a working .img if I extract it with 7zip or WinRAR

Thank you


(bpi team) #13

i have let our R&D to test it now ,and update late. sorry.


(bpi team) #14

we have download and test this image again, and not any issue.

please try zip or unzip to do this work on linux.

if you use windows OS , need NFS or EXFAT, can not use FAT32, it is limit for 4G,this image have 7.45G


(Leszek Szpunar) #15

I downloaded again and I tried on ubuntu linux:

  1. Downloaded from: https://drive.google.com/file/d/0B_YnvHgh2rwjRXg1bVpUbFFjb1U/view?usp=sharing
  2. Unpacked
  3. Inserted SD
  4. And I used the command: sudo dd bs=1M if=<.img path> of=

to no avail - still red light

I can find somewhere official instructions to install on M3?


(Philippe Trottier) #16

Here’s a trick:

dd if=something.img of=/dev/device bs=1M conv=fsync

the last part makes sure the card is ready to be ejected :slight_smile:


(Leszek Szpunar) #17

This also I tried, but nothing changes


(Leszek Szpunar) #18

someone was able to run? I give up :frowning:

I still have the red light :disappointed:

I tried everything…


#19

Because I also didnt get it working I have made some Pictures of the Problem maybe it will help someone.

Okay…

  1. I downloaded the Kali-Linux Image from the Google Drive

2. I extracted the .zip-File with WinRAR (I also tried it with 7zip and other Programs)

3. After finishing I get the following File (Picture 3)

4. I tried to convert the File to an .img File to write it with Win32DiskImager to my SD-Card.

finally only the red LED shines :frowning:

I also tried to write the “-” File directly to my SD-Card but it also didnt work.

Hope my english is understandable

greetings, root_Padi


(Leszek Szpunar) #20

I added .zip extension to “-” file. Unzip “-.zip” file - in the middle is .img file

but I still have red light.

You can install kali tools on ubuntu: http://www.techrepublic.com/article/pro-tip-install-kali-linux-tools-on-ubuntu-with-this-easy-script/


#21

Yes I konw :smiley: I have tried that too but your right it didnt work…

And Yes I know that you can install all the Kali-Tools on Ubuntu with Katoolin but it isnt the same :frowning: :smile: