BPI-M2U & Berry New Image Release : Ubuntu 16.04 & Raspbian 9.4 & Debian 9.4 2019-05-13


(ZB) #1

**BPI-M2U & Berry New Image Release : Ubuntu 16.04 & Raspbian 9.4 & Debian 9.4 **

M2U Ubuntu 16.04

M2U Raspbian 9

M2U Debian 9

1.About this release

  • This release is for banana pi M2U board which is based on A40I, R40, V40, and it is based on Ubuntu 16.04 & Raspbian 9 & Debian 9 Operation system with kernel 3.10.108.

2.BPI-M2U Ubuntu 16.04 Features Map

3.BPI-M2U Raspbian 9 Features Map

  1. BPI-M2U Debian 9 Features Map

FAQ.


#2

@Jackzeng, FYI:

I tried this image on a BPI-M2-Berry (with V40 CPU, not R40). This image uses a very old Linux kernel (3.10). With it the following problem occurs: mounting an ext4 partition that was created with a newer kernel version (here 5.x) is not possible; a mount error happens (see below). I also tried with mount-param “-t ext4”, but same error happens. fsck can be done (see below): the partitions are fine, but, as said, mount cannot be done.

I would suggest to update the kernel to at least 4.x, even better to 5.x.

I mean this server image for Debian : https://drive.google.com/open?id=1aoB8mGwSveNztB-EO_fBKLOr-GdzcMNV (referenced on this page: http://wiki.banana-pi.org/Banana_Pi_BPI-M2_Berry#Debian )


# uname -a
Linux bpi-iot-ros-ai 3.10.108-BPI-M2U-Kernel #5 SMP Fri May 10 10:12:10 CST 2019 armv7l GNU/Linux


# fdisk -l /dev/sda
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: ...
Device       Start      End Sectors Size Type
/dev/sda1     2048  4196351 4194304   2G Linux filesystem
/dev/sda2  4196352 12584959 8388608   4G Linux filesystem


# lsblk /dev/sda
NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda      8:0    0 465.8G  0 disk 
├─sda1   8:1    0     2G  0 part 
└─sda2   8:2    0     4G  0 part 


# lsblk -o NAME,FSTYPE /dev/sda
NAME   FSTYPE
sda    
├─sda1 ext4
└─sda2 ext4


# fsck -f /dev/sda1
fsck from util-linux 2.29.2
e2fsck 1.43.4 (31-Jan-2017)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sda1: 14/131072 files (0.0% non-contiguous), 520192/524288 blocks


# fsck -f /dev/sda2
fsck from util-linux 2.29.2
e2fsck 1.43.4 (31-Jan-2017)
Pass 1: Checking inodes, blocks, and sizes
Pass 2: Checking directory structure
Pass 3: Checking directory connectivity
Pass 4: Checking reference counts
Pass 5: Checking group summary information
/dev/sda2: 13/262144 files (0.0% non-contiguous), 36944/1048576 blocks


# mount /dev/sda1 /mnt/sda1
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.


# mount /dev/sda2 /mnt/sda2
mount: wrong fs type, bad option, bad superblock on /dev/sda2,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.


# dmesg | less -Sn
[  334.846451] JBD2: Unrecognised features on journal
[  334.846478] EXT4-fs (sda1): error loading journal
[  339.598250] JBD2: Unrecognised features on journal
[  339.598283] EXT4-fs (sda2): error loading journal


#3

Update / Fix:

kernel 3.10 seems to require that ext4 has no journal.
With the following commands one can delete the journal option:

# Delete the "has_journal" option:
tune2fs -O ^has_journal /dev/sda1

# Required fsck:
e2fsck -f /dev/sda1


Now mount works!


(Igor) #4

That is not so simple. A lot of features doesn’t work. Sticking to https://www.armbian.com/bananapi-m2u/ is far the best option. Regardless of the upstream kernel.org version.


#5

Thx, will soon try out also the linked Armbian image with the Debian Stretch OS.