BPI-M1/M1/R1 new image:Debian 10 buster mate desktop with grub support (boot-2019.07 + kernel 5.1.1)

BPI-M1/M1/R1 new image:Debian 10 buster mate desktop

  1. grub function support
  2. boot-2019.07
  3. Linux kernel 5.1.1

BPI-M1 debian 10 image:

BPI-M1+ debian 10 image

BPI-R1 debian 10 image:

1 Like

I tested this image on Bananapi M1+ and found that the serial port ttyS2 ttyS1 ttyS3 could not communicate

Root@bpi-iot-ros-ai:/home/pi# echo “kkkk” >/dev/ttyS1 -bash: echo: write error: Input/output error

Root@bpi-iot-ros-ai:/home/pi# uname -a Linux bpi-iot-ros-ai 5.1.1-BPI-Kernel #1 SMP Thu Aug 22 13:53:49 CST 2019 armv7l GNU/Linux

Can you provide build kernel documentation? I plan to build a lite os myself.

I have a BPI-M1 that has been running for several years from a PNY ssd and an old Armbian image - worked fine. I recently moved app to another server because there were no updates to the old image. I downloaded the image for Debian 10, put it on an SD card and it worked fine. I copied the contents of the SD to the newly formatted ssd and tried to GRUB boot it - no entry for the /dev/sda1 ! I installed os-prober and ran it and got the entry for the ssd os and tried to GRUB boot it again - entry for ssd-os was in the GRUB menu, but when I tried to boot it, I got no such device or file. I messed around with the menu and got the rescue (read-only file system) os to run from the ssd. How can I get the full os on the ssd to run using GRUB from the SD???

Move to most recent Armbian image and you will be just fine. It’s by far the best support.

Thanks, works fine!!