BananaPi BPI-M2Z(H2+) New Image Raspbian & Ubuntu Release 2018-07-09


#23

Hi,

Could you please make a build with Raspbian Stretch Lite? Also, what can I do to get the ethernet port to show when I run ifconfig?

Thank you.


(ZB) #24

Hello, I am preparing to release some other images in few days;

did you mean “ifconfig” in terminal?

I think you could use root user to execute ifconfig in terminal.


[BPI-M2+] New image: Android 7.0 (Version:V1)
#25

I don’t see the eth0 interface when I run ifconfig in terminal, only wlan0.


(ZB) #26

which board do you use?

could please you do “ifconfig” , “bpi-hw” and show me the log?


#27
root@bpi-iot-ros-ai:/home/pi# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:136 errors:0 dropped:0 overruns:0 frame:0
          TX packets:136 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11472 (11.2 KiB)  TX bytes:11472 (11.2 KiB)

wlan0     Link encap:Ethernet  HWaddr ...  
          inet6 addr: .../64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:108 errors:0 dropped:1 overruns:0 frame:0
          TX packets:123 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:9079 (8.8 KiB)  TX bytes:16528 (16.1 KiB)

root@bpi-iot-ros-ai:/home/pi# bpi-hw
bpi-m2z

(ZB) #28

Hello,BPI-ZERO doesn’t have RJ45 interface,it only has one wireless soc on board, you could connect Internet by WiFi


#29

I will try the solution described here: http://forum.banana-pi.org/t/getting-ethernet-working-with-banana-pi-m2-zero/6137/4. Thank you anyway for supporting this board.


(clemclem) #30

Hello, Thanks for this OS, i use raspbian on my banana pi zero M2 (H2+) and it works great. Except for the wifi that i had to set up manualy with this : http://wiki.banana-pi.org/Getting_Started_with_M2_Zero#WiFi_Client

MY QUESTION is about creating an hostpot with it. I use Raspap (wget -q https://git.io/voEUQ -O /tmp/raspap && bash /tmp/raspap).

All the installation works great, the configuration web page at 10.3.141.1 also works but no WIFI is available using my surrounding devices… Any idea? :frowning:


(ZB) #31

Hello, Did you connect Antenna?

and does sta mode work well on your board?

try “killall wpa_supplicant”.

then do “wpa_supplicant -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf”


(clemclem) #32

i do have en external antenna. I can surf on the internet well. what is sta, how do i check that?

Kill supplicant didnt work


#33

I have some trouble getting bluetooth to work with the raspbian image:

Job for bluetooth.service failed because the control process exited with error code.
See "systemctl status bluetooth.service" and "journalctl -xe" for details.
invoke-rc.d: initscript bluetooth, action "restart" failed.
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Mon 2018-11-05 23:43:59 NZDT; 529ms ago
     Docs: man:bluetoothd(8)
  Process: 1694 ExecStart=/usr/lib/bluetooth/bluetoothd (code=exited, status=226/NAMESPACE)
 Main PID: 1694 (code=exited, status=226/NAMESPACE)

Nov 05 23:43:58 bpi-iot-ros-ai systemd[1]: Starting Bluetooth service...
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Main process exited, code=exited, status=226/NAMESPACE
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: Failed to start Bluetooth service.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Unit entered failed state.
Nov 05 23:43:59 bpi-iot-ros-ai systemd[1]: bluetooth.service: Failed with result 'exit-code'.

Wifi is working fine.


BananaPi BPI-P2 Zero(H2+ with POE) Ubuntu server & raspbian images release 2019-01-16