WED and beamforming on BPI-R3

Yes, briefly tried to boot initramfs and seemed all fine.

Ok I used my usual build config which includes several packages, It might be that. Although there’s nothing special there. Let’s wait for the UART log then.

Do you want me to send you the image I built? I’m not sure when I’ll be able to test it again

@dangowrt Is this the commit that brings back support for WED in bpir3? https://git.openwrt.org/?p=openwrt/staging/dangole.git;a=commit;h=f1606a8360a8d707202d9608f4253e4e1f77b235 I don’t see anything specific to WED there, could you tell which part of it is relevant for WED?

@Dale do you have an example of what should we see in the logs if the WED worked? I will try to get it to run on my bpir as well.

It’s here in this commit. The patch is re-added, it has accidentally been dropped when copying patches from 5.15 to 6.1.

Can you test the 6.1 kernel?

can it be 6.4.11 ? (additional characters to satisfy minimum lenght)

What do you mean? You can either build with openwrt with 5.15 or 6.1 (unless you modify everything ofc)

I have totally custom setup with nixos :slight_smile:

is this patch enough or do i need anything else in 6.1? how to check if wed works?

Hi, Dale. Just thinking of moving from the most recent 5.15 snapshot to 6.1, but have no idea how to (I lack the experience and knowledge). Is there a simple way to do this ? Regards

https://openwrt.org/docs/guide-developer/toolchain/use-buildsystem Read this and for 6.1 I just manually change the target kernel version to 6.1 on the mediatek makefile. I’m sure there’s a build argument for that, but I’m too lazy to search for it. Maybe @dangowrt knows

Here’s the boot log

do you know where is located this file ?

Last time i compiled a new firmware from the dangowrt tree i didn’t see any choice, it was “main” and it made a 5.15 kernel firmware…

/target/linux/mediatek /Makefile

1 Like

You don’t need to edit the Makefile for that. In menuconfig under Global Build Settings you find the checkbox Use the testing kernel version. If that is selected, the current testing kernel version (6.1) will be used instead of the stable kernel (5.15).

If there is no testing kernel available for a selected target, the option simply won’t show.

2 Likes

I assumed there’s an option somewhere, just didn’t find it so I went for the lazy way

@dangowrt Did you get a chance to look at the boot log?

it only created an initrams image, is this normal ? image

No, there should be squashfs image as well.