Problem trying to use emmc

Hi, Ive got a bpi r2 and I’m trying to follow the instructions to configure it to boot from the emmc, for example from here:

When I try and selct the emmc device in u-boot I get this message:

BPI-R2> mmc list
mmc@11230000: 0
mmc@11240000: 1 (SD)
BPI-R2> mmc dev 0
Card did not respond to voltage select!
BPI-R2> mmc partconf 0
Card did not respond to voltage select!

After that runnign mmcinfo also says ‘Card did not respond to voltage select!’ so its selected the device.

I’ve tried with the 4.14 kernel from FrankW, and just compiled the kernel 5.4.46-bpi-r2-main.

u-boot version is: BPI-R2> version U-Boot 2019.07-bpi-r2-sata_new-00035-g915f1ef772 (Jul 30 2019 - 10:50:24 +0200)

arm-linux-gnueabihf-gcc (Ubuntu/Linaro 7.4.0-1ubuntu1~18.04.1) 7.4.0 GNU ld (GNU Binutils for Ubuntu) 2.30

I feel I’m mising something, anyone have any ideas where I’m going wrong?




As you have problems in uboot, you could try this:

Have you problems in linux? 5.4.44+ have the emmc-patch inside.

@lexa2 reported a similar issue…maybe emmc is broken

Regards Frank

Hi Frank, thanks for your super quick reply, and on a Saturday morning too!

That worked a treat, I built the latest u-boot you linked to, flashed my sd card with the u-boot.bin and now the mmc dev 0 and mmcinfo commands work as expected.

Sorry, the reference to the 5.4 kernel was a red herring, that works just fine and I can read/write the emmc from there.


Thank you for confirming patch works fine for you. I guess bpi-r2 v1.1+ needs this patch while 1.0 is not affected by this issue

@lexa2 can you check this with your board(s) too?

Seems like sec chips need this uboot-patch where samsung does not need it