CM4 with MCUZone board, no USB port works

I’m trying to get a BPI CM4 to work with a POE_SSD carrier board from MCUZone / Hangzhou WildChip Tech. The board itself works, so does the ethernet but none of the USB ports works. MCUZone says, their board is 100% RPI-CM4 compatible and BPI says, their CM4 is 100% RPI-CM4 compatible minus the second DSI/HDMI port. I tried Debian, Ubuntu and Armbian as well as various USB devices and nothing works. Any ideas anyone?

Tried now also the Android image. Same issue. So either my CM4 is broken or it’s not pin to pin compatible with the RPI CM4. I ordered an “official” BPI baseboard now for testing.

hi, In fact, there is no way to make it 100% the same as the RPI, but most of the functions are fine. We have listed different PINs on the wiki. In addition, our official baseboard is 100% all functions can be used.

Banana Pi BPI-CM4 - Banana Pi Wiki (

1 Like

Yeah, I get that it’s hard to get 100% compatibility but USB is a very basic function and I have to say that if you cannot guarantee compatibility of such basic functions, you shouldn’t advertise it as “pin-to-pin compatible with Raspberry Pi CM4”. I have ordered now a BPi baseboard and will test with that - maybe my module is just broken, who knows…

If you say “our official baseboard is 100% all functions can be used.”, you haven’t understood the idea behind compute modules and making compatible compute modules. Making a compute module that only works 100% with your own baseboards makes that compute module pretty much useless unless you make a lot of different baseboards. Otherwise you can as well just make a monolithic SBC. The whole point of compatible compute modules is that they work with all kinds of different baseboards.

I chose your CM4 not only because RPi CM4s are hard to find at the moment. I chose it because the specs look perfect for a project I’m working on but that project requires a very small footprint baseboard.

Is this board schematic of usb part different with rpi official cm4io board? maybe you can upload the io board schematic and console debug message from power on.

I guess your io board is the same hardware design as waveshare-io-base-b How to make CM4 work with Waveshare CM4-IO-BASE-B, the schematic of waveshare-cm4-io-base-b is, it’s different with official rpi cm4io board, it don’t have a hardware detect to switch from device to host mode, because this port is connect to a otg usb port of soc.

copy this overlay file otg-host.dtbo (354 Bytes) to /boot/overlays and apply it in /boot/env.txt


that worked! Thank you so much! You rescued my project! That solution should definitely be in the Wiki!