BPI W2 sources for Linux, etc

We’re working on it, and when it’s ready, it’s updated to github.

It’s been some months. Can’t buy without an open kernel & boot loader. No sources, no deal.

Linux HDMI issue have fixed ,we will update code and image soon w2%20HDMI

Sounds nice, but where actually is the code? The gitbook for example just links to binary blobs in a drive. Given that both U-Boot and the Linux Kernel are GPL code, it would be the natural thing to just work with the code out in for example a public git repository.

1 Like

Found new commit on github with new kernel so tried to use it:

Performed update via tools:

bpi-update -c bpi-w2.conf -d /dev/mmcblk1

All files that supposed to end up on boot partition (mmcblk1p1) ended up not in root of it but rather inside this path on that partition:


moved them manually to mmcblk1p1 root and rebooted my board

still green screen via HDMI and board will not complete boot cycle: bootlog.4.9.txt (65,6 KB)

left rootfs (mmcblk1p2) unchanged (state as left after update - existing modules for 4.9.119-BPI-W2-Kernel, etc) and just copied older files back to boot partition

board completes boot cycle on old kernel

root@BPI-W2:~# uname -r

What am I doing wrong?

test BPI-W2 network speed:


situation update:
flashed u-boot included in same commit to SD card with:

bpi-bootsel /usr/lib/u-boot/bananapi/bpi-w2/BPI-W2-720P-2k.img.gz /dev/mmcblk1

re-applied update as before (to re-create directory structure on mmcblk1p1):

bpi-update -c bpi-w2.conf -d /dev/mmcblk1

SW4 position 0 -> boots 4.4.18-ning (green screen on HDMI)
SW4 position 1 -> boots 4.9.119-BPI-W2-Kernel (black screen on HDMI)

UART console keeps getting this log on new kernel:

[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled
[AO][_AO_if_video_HDMI_mode]HDMI not enabled

when I halt the board - screen says ‘NO SIGNAL’,
when board is running it just stays black without any message

unable to check if any kernel module got loaded: lsmod or modprobe return ‘command not found’

noticed sth else (symlinks in kernel modules point to some folder not on my system):

root@BPI-W2:~# ll /lib/modules/4.9.119-BPI-W2-Kernel/
total 92
drwxr-xr-x 3 root root  4096 Sep  2 14:31 ./
drwxr-xr-x 3 root root  4096 Sep  2 17:13 ../
lrwxrwxrwx 1 root root    54 Sep  2 14:31 build -> /media/mikey/BPI-USER/github/build/BPI-W2-bsp/linux-rt
lrwxrwxrwx 1 root root    54 Sep  2 14:31 source -> /media/mikey/BPI-USER/github/build/BPI-W2-bsp/linux-rt

we have fixed HDMI issue on linux , please test this image :


here my bootlog Bananapi_w2.log_10 (40,3 KB)

Best regards

which image are you use???, just RPiTC image support HDMI , we will update other image soon .


how can i burn this image to eMMC?

Do we know when/if Raspbian will be available for this board? At this point, the board is mostly useless without a decent OS to run on it. We’re trying to get this ready to deploy for solar powered cameras on construction sites running our VMS. Here is a list of approved OS from the VMS company. Raspbian Jessie, Debian 8. I really don’t want to use Raspberry Pi, but if we can’t get this W2 board to work we will have too.

Please provide the source code for these images, particularly kernel and u-boot, as required by the GPL license.

we debug kernel now . and have working fine .


putty > weston > xming gives exactly as seen above

rtk_drm module is not loaded at boot:

cat /sys/class/drm/card0-HDMI*/enabled

says “file not found”, after loading manually it says “disabled”

Banana Pi BPI-W2 source code public on github


Hi! I saw this error log ([AO][_AO_if_video_HDMI_mode]HDMI not enabled) when I tried to use fstab to mount some disk automatically. Firstly I thougth it is because of the power supplytoo weak… but now I have stronger and the situation is the same. Can you tell me please what does it mean? I do not need hdmi at all for me the w2 is a headless server… but I would like to use fstab :confused:

Hey, the HDMI not enabled-error is not the reason for the fstab-mounting-and-not-booting. It is shown whenever the boot process can not finish (I think).

You have to tell fstab to mount the disk only if present and without waiting for it at boot. The option is called nofail (there is also nobootwait, but thats not supported)

You have to add this options in your fstab-line:

UUID=XYZ MOUNTPOINT FILESYSTEM defaults,errors=remount-ro,nofail 0 2