[BPI-R64] OpenWRT kernel 5.4.40 running from eMMC

Thank you, but I still need to load EEPROM for MT7615. As we discovered in this thread my board doesn’t have any preloaded calibration data.

Then you need to add function for loading eeprom from file,this is how i did it:

Thank you. I will try it.

/lib/firmware/mediatek/%s_rf.bin is the path for EEPROM file? What does %s stand for? For MT7615 File should be named mt7615e_rf.bin?

P. S. Looks like you all made a great job and quite a progress since autumn.

right %s is placeholder for driver name (dev->dev->driver->name). for files/filenames see https://github.com/frank-w/BPI-R2-4.14/commit/d1bc0e34c56d00663cd36b2242a924738924ef8c

Do I need to make these changes to eeprom.c only or to mt7615/eeprom.c too?

afair load-code is only in “global” eeprom.c, chip-specific is only interpretion of fields…just try to apply my patch and place files in your filesystem. make sure mt76 is compiled as module.

Thank you for your wonderful job on making OpenWrt work.

However I’m stuck in a rather ridiculous situation: I’ve applied patches from @frank-w to load firmware from files, compiled OpenWrt, installed it on an SD card (and eMMC), have a working board with working WiFi, but it doesn’t have LUCI or uhttpd. Even though I’ve checked LUCI in menuconfig as a module. Could you give some advice on where to dig further?

Is uhttpd listed when you call: opkg list-installed?

Not unless I choose LuCI as built-in in menuconfig [*] indtead of [M].

That’s the intended outcome then. If you want things to end up in the generated rootfs, you need to select them as * ie. built-in in OpenWrt’s menuconfig. Otherwise the build system will generate .ipk packages but will not install these packages in the generated image.

Thank you.

That means that I need to create my own http server with all the packages? Or I can use mainline repo?

Hi Guys, I have a question, does the BPI-R64 will work with the “OpenWrt-21.02”, where it uses the kernel 5.4. I tried it but wasn’t successful. An official branch of “OpenWrt-21.02”, when chosen BPI-R64 it doesn’t generate the img file, just sysupgrade bin file. When tried to upgrade with the bin file wasn’t successful. Could you guys point out how/which changes or patches needed to build OpenWrt-21.02 for BPI R64