BPI-R64 new image : LEDE17 (OpenWRT) image Kernel:4.4.177 SD&eMMC booting 2020-04-09

Mmc 1 is sdcard not emmc (which is 0)…i guess uboot configuration is wrong. I do not have an idea about invalid env…

Maybe uboot is too old and have no emmc-support (early versions had problems with emmc)?

I was able to get it working using another image from this forum.

Now I’m able to build openwrt from development branch (5.4) and write kernel to emmc. The only problem now is that it cannot save configuration after rebooting.

I’ve selected the rootdisk option in menuconfig, but there is no way to use the .bin.gz image and make it work. I’ve tried writing it directly to kernel, tried extracting .bin and writing to kernel, tried sysupgrade from luci as well, none of these options work at all. The only bootable image is initramfs-kernel.

Any ideas how to flash .bin.gz image to emmc? Different partition required?

which configuration do you want to save? from openwrt or from uboot?

maybe you need to replace uboot with one that has emmc-support, but i don’t know if openwrtuses same uboot-location as other images (https://wiki.fw-web.de/doku.php?id=en:bpi-r64:storage u-boot-mtk.bin at 0xC0000) and boot needs to be done from partition 0:x (eMMC) instead of 1:x (SD). maybe you have to adjust cmdline (root=) to be also on emmc

I want to be able to save configuration from openwrt. It gets deleted after each reboot.


gen_mt7622_emmc_img.sh seems to generate the image

i guess you have read-only rootfs and no squash-fs above (or it is not written back to persistent storage).

gen_*.sh does not show uboot location

I can not use wifi, how can I setting it. when I ifconfig up the board is stuck then reboot.

version is [ LEDE17 (OpenWRT) image Kernel:4.4.177 SD] attach is log. who can help me ? thanks! issue.log (254.6 KB)

I’m not sure mt7622 wifi is supported…or do you try to enable another wifi (card)?

I see no crash in log only many errors from jiffs

frank thanks for reply!

I try ifconfig up ra0 can up successful. but if I try ifconfig rai0 up, it stuck then reboot. I use MT7615 with pcie connect on onboard. error like below is normal? [ 84.965987] rtmp_cal_load_from_bin::FileName=/etc_ro/Wireless/iNIC/CALDATA2.bin [ 84.973354] RtmpOSFileOpen(): Error 2 opening /etc_ro/Wireless/iNIC/CALDATA2.bin [ 84.980759] Run RXDCOC/TXDPD/PRECAL cmds to generate caldata files [ 84.987905] rtmp_ee_bin_init(): bDCOCReloaded = false. [ 84.993050] rtmp_cal_load_from_bin::FileName=/etc_ro/Wireless/iNIC/CALDATA2.bin [ 85.000368] RtmpOSFileOpen(): Error 2 opening /etc_ro/Wireless/iNIC/CALDATA2.bin

do I need load some data in partition to support it?

this looks like you need this file (verify it does exist)…seems some kind of calibration data…imho reboot is caused by a crash (afair openwrt reboots on oops/and panic). as this driver is closed source we can not help much. you could try using newer kernel version which has mt7615 opensource driver

thanks! . I missing /etc_ro/Wireless/iNIC/CALDATA2.bin only have /etc_ro/wlan/MT7615E_EEPROM2.bin . I first start with board. I try the firmware from wiki, because see it support full MT7615. I will try new firmware.

I guess driver in 4.4 does not support all features (maybe firmware is not compatible). For nearly full support try 5.9 (imho this is going to be next lts)

frank, do you know how to build the SD card image. I have compile openwrt 4.19, openwrt-mediatek-mt7622-BPI-R64-SD-squashfs-sysupgrade.bin. I wan to boot from SD card.

thanks, Water

no, i don’t use openwrt…@dwmw2 does some work in openwrt for r2/r64

i guess if you have built the sysupgrade image you only need to dd it to sdcard

thanks, frank!

@dmw2, could you help me, I want to write build.sh to auto create SD img. in my cognition, full bootup device, we need write many file(uboot xxx) to build it or replace the kernel and rootfs partition then can use.

Have you got the source code?Can you share it?