[BPI-R64] Debian Bullseye image

Thank you so much for this information. My point is this, that I don’t want to destroy this board with incorrectness PowerSupply…

Best regards und take care…

Hey Frank-w, First of all, I would like to thank you again, because the power connection worked great.

However, what I have already noticed is that the WAN port responds and is visible with the IP address given in this blog.

But the bridge IP does not work for me yet. What could be the reason for this? I will first go there on the weekend and adjust the WAN address to my ratio. How can I do this with the WLAN? Have you installed a web server in this IMAGE?

Bet regards

Z. Matthias

wan works and lanbr0 not? just login (debug-uart/ssh) and show output of “ip a”

webserver is not installed as it is a very basic image (minimal install), but can be easily installed via apt

not everybody wants a webserver on a router (like me) :slight_smile:

Hello Frank-w,

Thank you very much for your help. Unfortunately I didn’t make it at the weekend, I was a bit displeased by the disagreements at work. Now I was able to put the BPi64 into operation today and was very surprised at first about the speed and your great image.

It works perfectly on the WAN port. I will try out the LAN bridge in the next few days. I executed the “ip -a” command and you can really see the IP address here (see screenshot). I’ll take a closer look when I attach a small PI4 to it.

I got an error message with the command “fdisk -l” regarding GPT backup, can you do something with it? (Screen shot attached).

Questions: Can I set up a SWAP area for myself? It tells me under “swapon /dev/…” that this is not possible.

How do I now connect the WLAN interfaces? Does it make sense to set up a separate bridge and network here too? And have you installed a DHCP server on this image for the automatic allocation of IP addresses on the LAN & WLAN?

Thank you in advance for your effort and support.19 10

GPT saves a backup of partitiontable in last sector of card, as every card has different size there is no backup-gpt…only the main at beginning of the image. you can try fix it with sgdisk or (g)parted. but maybe it breaks the bootsector and you need to reflash the first 2MByte (to restore them from the image again) how do you want to define the swap (partition,file,…), i left some space after the root-partition for data, you can simply add a partition there and map it as swap. or you need to move/resize the root-partition to the end to have swap before, but then you need to change rootfs-number in uEnv.txt and fstab so better add it after root-partition

i do not use bridge for wlan…only setup hostapd on it and set ip-config directly to wlan0 dnsmasq should be installed, but only lanbr0 is configured (afair i had prepared wlan0), just look in the /etc/dnsmasq.d/interfaces.conf and change it

Thank you for the quick reply.

I wanted to set up a SWAP volume on the eMMC storage. I have already created the partition and defined it with mkswap. But with the command “swapon /dev/…” I get this message:

swapon: /dev/mmcblk0p2: swapon failed: Function not implemented

What could this be?

maybe filesystem is not supported in kernel…have not done anything with swap on bananapi, afair it is a special filesystem (at least the partition-type is special)

btw. using the emmc (which can’t be replaced) as swap is imho no good idea

Okay, I’ll take a look at that at my leisure. I haven’t done the “hostapd” yet. I’ll also have to see how the IP address behaves there, etc. Is there any information / tricks from your side?

I do think that the eMMC for SWAP is a good idea. Firstly, it’s incredibly fast and secondly, it’s rebuildable if I have to set up the router again…

maybe i have already added hostapd config to the image without enabling it

have written down some hints here: https://www.fw-web.de/dokuwiki/doku.php?id=en:bpi-r2:wlan#mt7615

…but I can’t seem to build or use the one with the SWAP. SWAPON does not allow the use of a /filesystem or /file. Okay, I hope that there won’t be any bottlenecks.

Before I do something wrong, Frank. Which WLAN drivers are sometimes installed in this IMAGE? Because I don’t see any at “ip a” at the moment and I don’t necessarily want to do anything wrong.


modprobe mt7615e

and mt7915 should be similar see my defconfig

for swap try clone my kernel-repo, change build.conf to bpi-r64, run ./build.sh importconfig and ./build.sh config and search ("/") for swap…i guess there is something missing

Thank you very much. When I enter the command “modprobe --show mt7615e” or even without “-show”, the system shows me nothing. If I change it to a capital “E”, then it tells me that it would not be there.

Thanks, that’s a bit too tricky for me right now and will leave the SWAP out for now. If I notice that the system is getting too slow, then I will take another look.

It’s important for me to get the OpenWRT running properly first and then back up this SD card as an IMAGE, if that goes well.

I also have a feeling that I will have more questions. Should I do it via this or rather via email?

you can do it in forum, but please in separate threads as they are not related to the image itself



not enabled for r64

Good morning, Frank. …once again my thanks for the help/support.

So far I have been working with your Bullseye image for the BPI-R64 and have found that the LANBRIDGE only works when the WAN interface is active. Before that I had no possibility to access this system (via LANBRIDGE). My next step will be to set up the “BASICS”, i.e. a DHCP service for the LANBRIDGE side, and then I will work on the WLAN configuration (I will also write about this in another section).

But one more thing: When I enter “ipconfig -a” I see a WLAN0, where does this come from? Does this stand for the internal 4x 2.4 GHz connections or should 4x WLAN also appear there? I have also installed the 5 GHz module. Do you have any idea how I can deal with this board? Installation Driver, Access…

Kind regards

Z. Matthias

I guess this comes from the systemd-config.

Wan is configured if link is there and requires eth0 to be up (bind),lanbridge should always be setup,but only up if link on any port is set. Maybe the binding to eth0 is missing (needed for lan0-lan3 too).

Wlan0 i guess its the internal…you don’t get 4 wlan interfaces…only one…you have only 4 antenna connections. You can srarch dmesg which wifi device is recognized,but wlanX is imho only printed if renaming is done…sometimes renaming to wlp0sX happens sometimes not

You can choose the wlp or wlan naming scheme in the systemd .link file…


1 Like

thanks, but currently i have no .link for wlan devices…and afair internal wifi is named wlan0 and external (pcie card) is renamed to wlp1s0