BPI-R2 slow ethernet speed

I do not. I have restored the DTS to the contnet from your repo with pause enabled on both the gmac and swtich

so the crc-offloading also causes the timeouts you have? how much is your throughput without the crc offload? i guess it causes some cpu-load/interrupts…but how much?

Seems to top out around 890Mbps if you set ipref to skip the first tests in the stats. Not sure on the interrupt rate but it is cpu bound at this point. If you open htop on virtual console while ipref is running it maxes out one CPU core. That does not seem to have a lot of real world impact on my actual work loads. With all my containers running it still seems fairly responsive doing smb/www/dvb-streaming/nat’ing and fire-walling for a few client PCs at once. That fact that its stable now means I can finally shut down the old kirkwood unit I first bought an r2 to replace move the file storage over; and it will still be MUCH faster :slight_smile: .

I’d still love to get to the bottom of it, because more headroom to do more stuff in the future with some confidence would be nice. That and it just bothers me…

In driver it looks like flag for hw checksum is set here


Tx offload: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/ethernet/mediatek/mtk_eth_soc.c#n949

Rx: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/ethernet/mediatek/mtk_eth_soc.c#n2232

This looks strange to me (like ising the checksum field for anything else): https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/ethernet/mediatek/mtk_eth_soc.c#n1177

I will try if this fixes my streaming-issue

I think it may be using the same flag to turn off segment offlaod as well. I did not get to spend as much time with this as I had wanted to last weekend. Life happens…