BPI-R2: HDMI 4k-TV fail

You see no fb console like me? Only x-server is corrupted and i see traceback while starting it and after

No, I can’t see fb console, it’s corrupted, and i have backtrace in dmesg on boot(or on hdmi-cable connect). I didn’t tried Xorg.

Google Photos

The TV shows that it’s in 2160p mode.

Mhm,i thought i have it partially working :frowning: i can’t apply atomic patches as they depend on others

Some good news! :smile:

After comparing 5.12-hnat anf 5.13-main I found a couple of patchsets to test…

And this set worked: https://patchwork.kernel.org/project/linux-mediatek/patch/[email protected]/

I’ve applied the whole series

Both Xorg and FB console seems to be fine:

r2-gentoo ~ # uname -r

Google Photos

Google Photos

Later I’ll try to run it on 5.10/5.11, not sure if it’s easy/necessary to backport it to 5.4.

P.S. if i’ll have some time i can test if rdma threshold and other patches are needed, but at low priority as there’s looks line no negative side effects.

1 Like

Nice, i guess backporting to latest stable (5.10) is enough. Have you tried reverting the patches i applied?

Btw. linked patch has a change while applying to drm-next (5.13) as stated in comments:


Not yet, testet on top of your branch, i’ll update after trying

indeed this patch (only applied the first of series as second adds only config for other chip) fixes 4K. Reverted some of the previous patches, and it is still working…see 5.12-hnat-branch

and it look slike this is the only patch needed in 5.10…have applied it to 5.10-main (no rdma patch) and can see the x-server on 4k-screen…

can you confirm it?

I’ll check it on weekend.

20/09/21 UPD: tested - works both fb console and Xorg.

1 Like

Thanks,i wonder why i had not tried the patch earlier…i pointed to same here