BPI-R2 Debug UART Desperation

I’m unable to connect to the debug UART (to diagnose a boot problem). I have tried two different FTDI adapters, three Prolifics, and one CP210x. I’ve tried them all on a Windows desktop and a couple of them on a MacBook. Every time that I connect, I get this type of garbage:


I’m starting with 115200/8N1 and no flow control, but I’ve also experimented with other speeds, bit counts, etc. If I setup the USB UART with a loopback, everything looks good. I’ve tried putty, Tera Term, and zterm with the same effect.

Any ideas?

Tx connected to rx and rx to tx. Ground connected? Leave profilic an test only with the cp21xx

Yes, I had RX & TX crossed over. Ground was connected too.

You use the debug-uart-port not gpio-header? Which image do you use?

Have you tried different cables between usb2uart and r2?

Debug-uart-pins soldered properly?

Yes, I’m using the debug UART port, not the GPIO. I’ve tried a bunch of different cables and the pins appear to be well soldered. I’ve managed to fix my original problem in other ways, so I’m putting the UART problem off for another day. Thank you for your help.

I had same issue with debug UART port. I solved it by changing the speed to 921600 bauds. It is 8 x 115200. It seems that there is an issue with the UART clock. Now I can use debug UART port with putty with no problem.

1 Like

Which system (image + version) do you try to boot-up?

Could you try my debian/ubuntu (to sort out software/hardware-issue)?

It was the preinstalled Android system. I’ve just bought and installed my Banana PI R2. My goal is now to change the system, and install something else. Yes I can try your image if you provide to me a link.

[BPI-R2 new image] debian 10 buster image with Kernel 4.19.62

@Plazuzu have you also used (preinstalled) android while you have the issues?