BPI-R2 2.4Ghz and 5.6Ghz Wifi Working fine

Is it possible to load firmware at boot time? I think just this two lines :


stp_uart_launcher -p /etc/firmware &

Kernel is 4.19, debian 10 buster. I’m planning a schedule of wifi AP, for example between 22:00 and 06:00 turn it off. Furthermore it would be nice to make AP “reboot-proof”, so after an unplanned system reboot it could run again!

Take a look at my wifi.sh on github…i call it via rc.local so it gets configured on bootup

For wifi-ap sheduling you can kill hostapd on 22:00 and start it on 6:00 via cronjob

I’ve been using your script and it’s perfect! Unfortunately, rc.local doesn’t seem getting it configured at startup! I’ve tried it several times, but no idea! :roll_eyes:

On buster (maybe stretch too) you need to create/enable systemd-service for rc.local


Working again, as I expected! :slight_smile: It’s great!

Thank you Frank!

But I slightly modified the wmt_loader script and placed it in the init.d directory. Then turned it on as a service. And when the system starts, the wifi starts and works.

Hi all, here is just a warning to end-users: be really thorough in visual inspection the moment you receive the board. Make sure to paitiently look at each and every square centimeter for misplaced SMD components as s*it happens and you might get a board like I got, check the attached picture below:

It is a typical case of misplaced component by pick-n-place machine. What is funny is the fact I wasn’t experiencing any major problems with WiFi on this particular BPiR2 board (well, expect for usual problems all users have related to the poor quality of the driver). I’m capable of fixing this one myself thx to my experience with smd soldering and the fact I’ve got required tools standing by ready to be used on my second work desk. Chances are that some other end-user won’t be that lucky. So I repeat once again: inspect the board as thorough as possible the moment you receive it. It might be easier to RTM it for exchange than trying to find some local shop to do a fix for you.


Hey guys. I’m newbie in openwrt, and just tested latest RC on my bpi-r2.


Working good, but there is no wifi enabled on it =(

Could you please help me to enable WiFi module on it because I’m a dumb =)

R2 wifi driver (mt6625l) is not available in official openwrt. You can get it on my repo (www.github.com/frank-w/bpi-r2-4.14) and try to integrate into your openwrt source

@frank-w thank you for help!! Does repo( www.github.com/frank-w/bpi-r2-4.14 ) has any diff with patching kernel? Or maybe short manual where I can get driver sources?

It depends on kernel-version you are using. Basicly i have 3 commits per -main branch for wifi-driver (driver folder itself, including it, changes outside) followed by maybe fixes. So better use these 3 commits from 1 version higher that your kernel version.

E.g. if you use 5.10 you take a look into 5.11-main. As i normally do not update the non-lts branches you will find these commits easily


maybe include the other fixes added to this tree

@frank-w I’ll give it a try, thank you :slightly_smiling_face:

If you succeed with openWRT, can you post your image for testing?

1 Like

@frank-w im trying to compile dirver, but i’ve got error

ERROR: modpost: "mtk_wcn_wmt_set_chipid" [/home/user/openwrt/build_dir/target-arm_cortex-a7+neon-vfpv4_musl_eabi/linux-mediatek_mt7623/mt6625l/connectivity/common/common_detect/mtk_wmt_detect.ko] undefined!

It seems to be some Makefile mistake. Maybe you know how to fix it?

i guess this error came because you try an incompatible/older version of the driver

you can get a working version for your kernelversion in my repo

Which kernelversion do you use and which version of driver…i remember i had this error in some 5.x kernel,but do not know how i have fixed it

@frank-w My kernel version is 5.10.134, and I’m using 5.11-main as you suggested. But I did not apply patches yet.

Could it be patch problem? And could I use newer version (e.g. from 5.12-main) with 5.10 linux kernel?

How do you use 2 kernelversions without applying patches :thinking:

You mean wifi driver from 5.11 with 5.10 base kernel?

Make sure you use only the first 3 patches from the driver (driver folder,include driver, changes outside driver dir), additional changing things for this newer version an may be not backwards compatible…

Yes, exactly. Ok, i’ll try to apply patches, may be it fix it.

And if it won’t work, can I use wifi driver from your 5.12-main branch with 5.10 openwrt linux kernel version? Or its forbidden? =)

It’s not forbidden :slight_smile:

Ok,you use openwrt… then it is maybe more complex as openwrt contains backports especially in network segment. That makes it hard for me to say “use version xy”.

You could try using all versions above your base version till one works (except 6.0 which is currently broken) or use the 5.10 version (squashed into 3 patches in 5.11 branch) and apply patches one-by one i added in newer versions (fixing specific problems).

@frank-w ok, thank you!