Bluetooth on latest image: ubuntu 16.04 V1.2.1 BT and WIFI AP mode are working fine 2017-11-27

Hi all,

I’m trying to get BT working on the latest image. I can scan devices with hcitool scan and I also see devices in the result. However I can’t connect using any tools and it seams that the kernel module RFCOMM is missing.

Have anyone successfully used the bluetooth?

Thank you in advance!


there is a thread regarding this with debugging waiting for vendors information

@garywang any new infos?

We will check this issue, and update you once we have any clue.


I’m very interested in getting BT to work? Can I do something to help?


I’ve tried some ways to make BT work well, but it didn’t work out. here is my menuconfig, I almost enable all drivers:



I tried rfcomm, and when I use rfcomm to connect my phone, my phone is also giving a respose to me. but it need pair pin code, I tried many ways to set pin code, but I failed.

I also tried bluetoothctl, it could config pair pin code, but it says no default controller available.

is there anybody have idea?