BananaPI-W2 Ubuntu 18.04 New Image Release 2018-09-17

I downloaded the kylin file again and retried the process but my computer still isn’t recognizing any drivers for the w2 in those files for some reason

Have you unpacked them from zip?

Yes and then I unpacked the actual drivers for Windows 7

  • I have plugged w2 to my laptop via usb-c (w2 powered from laptop via same cable at this point)
  • win 10 device manager said unknown device
  • update driver -> let me pick one manually -> selected folder as seen in screenshots (unzipped win10 drivers in there first, but zipped version was there as well)
  • update went well
  • device manager said ‘realtec generic usb device’ (details said ‘code 45 - device not plugged in now’ or sth like that)

at this point I have continued with SPI flash guide

  • started tool - android icon showed up (even when device manager still said code 45 as above …)
  • flashing went well
  • issued command as in guide via uart session
  • rebooted with sw4 on 1
  • saw latest date on SPI rom as in guide

maybe you are looking for issue where there is none…

1 Like

I’m using windows 7 but I just remembered that there is another computer in the house with a newer os so I’ll try that cpu now

I tried on another computer with windows 7 and it did the exact same thing as my laptop

Is it possible to run this image from SATA SSD?

Hmm are you sure USB button register being pressed while you power on the board?

My exact setup was no SD card inserted, sw4 on 0, USB button pressed. Plugged usb-c cable while still having USB button on w2 pressed. Released button moments after LEDs were all lit up.

You can plug uart at the same time as trying this guide - you will know if it boots as usual (no USB button registered) or you have few short lines (less than 10 characters each - USB button active)

bpi-iot-ros-ai login: root
/usr/lib/ubuntu-release-upgrader/release-upgrade-motd: 31: /usr/lib/ubuntu-release-upgrader/release-upgrade-motd: cannot create /var/lib/ubuntu-release-upgrader/release-upgrade-available: Read-only file system
mktemp: failed to create file via template '/var/lib/update-notifier/tmp.XXXXXXXXXX': Read-only file system
run-parts: /etc/update-motd.d/95-hwe-eol exited with return code 1
/usr/lib/update-notifier/update-motd-fsck-at-reboot: 33: /usr/lib/update-notifier/update-motd-fsck-at-reboot: cannot create /var/lib/update-notifier/fsck-at-reboot: Read-only file system

some time hapen this.

Wow…now that I followed your directions it is loading the drivers lol

My computer was loading the drivers but said “this device cannot start code 10”

After loading the spi rom tool my board is bricked. It’s not even registering on my computer now

Hi Kamil_S, I followed your instructions, having no SD card, setting sw4 to 0 and keeping the USB button pressed while I connect usb-c to my Windows 10 PC. The red and green LEDs light up and I release the USB button. I run the Kylin usb tool, rtumdfsample.exe, but Device 01 shows a gold gear on a black background, like all the other device icons. I run Device Manager and see “Unknown device” listed under “Other devices”. The details tab shows a value of USB\VID_0BDA&PID_1195\5&2CC31E78&0&1, and no driver. When I go to the Driver tab and attempt to update the driver from C:\Users\Ed\Downloads\bananapi\Kylin_usb_tool_ver.0008.1005811\usb_driver, where I downloaded the software, it reports “Windows was unable to install your Unknown Device”. Then I realized that the driver in the usb_driver folder was still zipped. I unzipped it and tried the update again. This time, it found the Realtek driver and installed for Realtek generic USB Device; however, Device Manager was now listiing it as an unknown USB device and it was still not recognized when I re-ran rtumdfsample.exe. I had to disconnect the w2 from the usb, hold down the USB button and reconnect it to the PC. Now Device Manager shows it as Realtek generic USB class and rtumdfsample.exe shows the Android icon for Device 01.

I’ll now continue with the instructions and see if I can successfully load Ubuntu 18.04, and report back with the results.

Might be I needed power down and plug back as well. Anyway - that was exactly my steps there. Flash SPI rom as in guide. Prepare SD card (flash image via etcher or any image to SD card you find out there) Power down board, plug SD in, switch sw4 to 1 and boot (via USB c or power barrel). It should boot just fine with HDMI working.

Ever since I flashed his spi rom tool the board isn’t recognized on my laptop at all unless I do the usb button and when I do that I can flash the spi again but I can’t see what it’s doing via serial any other time

Yes, it is now successfully booting Ubuntu 18.04 and displaying via the HDMI port. However, I have no internet connection. When I plug the ethernet cable into the GbE LAN port, only the yellow light on the left flashes. I’ll double-check the cable, but it was working fine with a different device.

At the moment there is only eth0 visible by the system. Issue ifconfig in terminal to see if you have valid IP or ‘ethtool eth0’ to see if it actually detected phisical link. Possibly try another Ethernet port on your w2 (maybe you are plugging in to eth1 that is not working at the moment)

Your spirom update has done nothing but brick my 100$ board

I have built my OS Image with the u-boot and Kernel using the BSP but found some issues with HDMI out and Gbit ethernet.

I have read some users with similar issues i have found but some does not complain about such problems. I just opened an issue on github in case someone has experienced this issues, or if already fixed please provide some guidance.


@Jackzeng can you please check if you have these issues building with gcc 7.3.1 as the latest commit? pre-built u-boot is with old gcc.

I have built kernel using last commit. Actually built all (opt 1) - just didn’t have flashed uboot (using the one available in base image).

Eth0 works normally and I am getting IP from DHCP running on my router. Eth1 is not detected at all (same as it was in 4.9 kernel in this image - eth1 worked on 4.4 but no HDMI there). HDMI out works normally on kernel I have built myself (just no CEC from TV plugged there :frowning: ). All I have changed from config available in commit is added raid (built in raid1 - others as modules) and enabled btrfs support.