[Banana Pi BPI-R64] Mainline OpenWRT image

Imho in openwrt Env is stored in separate partition which should not be erased on update

1 Like

Works but imho not nice (erasing environment maybe changed by user without asking)

Hello guys. I’ve tried to compiled the lastest version with linux kernel 5.4 and ext4 filesystem but boot failed. I copied the config-5.4 file from @graphine 's r64-emmc branch. The system hangs with “starting kernel…” and been reset after watchdog timed out. Can anyone help me to solve the problem?

That branch is no longer updated since @dangowrt added mainline support for r64 , as stated in the first post. You can build from openwrt master (squashfs + f2fs overlay).

News: OpenWrt contributor Oskari Lemmela wrapped up booting the BPi-R64 entirely from the SPI-NAND chip. SD Card will allow installing OpenWrt to SPI-NAND.


Hello everybody! Tell me if there is an OpenWRT image for R2 in which SATA and PCi-E work ? I will be very grateful for the link. I want to install Samba+transmission + wi fi(Atheros AR928X)

You can activate sata (and disable 1 pcie) by running this:

The other pcie should still work

I asked about R2 on it 1 PCIe

Ah,sorry. On r2 sata and pcie can be both used with mainline kernel. Limitation to choose between pcie1 or sata is only on r64

Thank you for your work! I don’t have a good knowledge of linux, OpenWRT. using the image OpenWRT SNAPSHOT r 164-e887049fbb / LuCI Master git-21.088.74150-ba4e214 was able to install wi fi(Atheros AR928X) but it is not possible to mount a sata HDD. The HDD is not detected by the system. Perhaps someone has a ready-made Openwrt image for R2 where SATA and wifi work out of the box ?

I do not use openwrt,but with mainline kernel i had no problems with sata in debian and my hdd (currently using 5.4)

Anything related in logs/dmesg?

dmesg.txt (56.4 КБ)

[    7.880334] ahci 0000:02:00.0: version 3.0
[    7.880359] ahci 0000:02:00.0: enabling device (0140 -> 0143)
[    7.886271] ahci 0000:02:00.0: SSS flag set, parallel bus scan disabled
[    7.892939] ahci 0000:02:00.0: AHCI 0001.0200 32 slots 2 ports 6 Gbps 0x3 impl IDE mode
[    7.900955] ahci 0000:02:00.0: flags: 64bit ncq sntf stag led clo pmp pio slum part ccc sxs
[    7.910562] scsi host0: ahci
[    7.914184] scsi host1: ahci
[    7.917367] ata1: SATA max UDMA/133 abar m512@0x60100000 port 0x60100100 irq 224
[    7.924808] ata2: SATA max UDMA/133 abar m512@0x60100000 port 0x60100180 irq 224
[    8.262067] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[    8.269097] ata1.00: ATA-8: TOSHIBA DT01ACA050, MS1OA750, max UDMA/133
[    8.275640] ata1.00: 976773168 sectors, multi 0: LBA48 NCQ (depth 32), AA
[    8.283354] ata1.00: configured for UDMA/133
[    8.288035] scsi 0:0:0:0: Direct-Access     ATA      TOSHIBA DT01ACA0 A750 PQ: 0 ANSI: 5
[    8.297310] sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/466 GiB)
[    8.304840] sd 0:0:0:0: [sda] 4096-byte physical blocks
[    8.310118] sd 0:0:0:0: [sda] Write Protect is off
[    8.314924] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    8.315006] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    8.348114]  sda: sda1 sda2 sda3
[    8.352654] sd 0:0:0:0: [sda] Attached SCSI disk

Looks good so far…have you tried mounting sdaX?

Thank you, everything works. Strangely, the processor became very hot, I did not notice this before

Which processor? From r2 (mt7623,mt7530,asmxxx),hdd,…

The processor MT7622 and especially the switch MT7531 are very hot (60°C) also on my board. I attached heatsinks on top of these chips. I can touch the heatsink of the CPU but the switch for not long time. The board nicely fits in the case of an old Wyse Cx0 thin client PC.

1 Like

I’m using Openwrt with 5.10 kernel but can not get PCIe working. lspci just gives nothing. GPIO 499 stays in low level, I can’t switch it to high. Suppose this is the reason. Also tried a build from BPi 20210501 but getting jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 on load

on r64 gpio 90 is used for switching between sata (low)/pcie (high)

additional to this your codebase needs the pcie-splitting patches to use both pcie-slots

I got GPIO number from here. It says that we should sum 409+xx, where xx - GPIO number we need. But anyways, I get write error: Resource busy