Banana Pi BPI-R4 BPI-BE14 Wi-Fi7 NIC module

I’m trying to get Wifi6 working on @danpawlik Build not Wifi7.

Am I confused or missing something?

Two posts above is an answer. It is on the openwrt forum.

trace above is caused by

and it seems interface is in state NL80211_IFTYPE_ADHOC

        if (WARN_ON(types & BIT(NL80211_IFTYPE_ADHOC) &&
                    c->beacon_int_min_gcd)) {
                return -EINVAL;
        }

not sure why only 1 phy is affected here (the other 2 are probed completely).

added a revert in my 6.11-rc tree and of course reported back to submitter.

Also got info that mainline patches/firmware for be14 (233) and others are prepared by mtk

3 Likes

You got info that they are working on the mainline patches for the BE14? That’s great news

Did you got info about what kernel they are working for? Public repo indicates that they are still working/developing for 5.4 …

Yes they talked about mainline support…downstream support (5.4) is already there.

1 Like

5.4? That’s that old firmware they put out isn’t it? It’ll be great when something 6.1 or newer comes out, but it’s great they are working on it. Also thanks for all you’ve done as well.

WiFi 7 board doesn’t work for me both in MTK MP3.1 and MTK MP4.0 official builds. Radio devices always stay inactive (didn’t do anything else beside restarting devices in LuCi). I’ve got it partially working (2.4 GHz only) in a custom build by @danpawlik, so the board is at least somewhat functional. Does anyone have an idea how to get it working in Sinovoip’s OpenWrt?

Kernel log of the MTK MP3.1 build attached.

kernlog.txt (125.3 KB)

I believe you have to activate the wifi through the MTK menu instead of the network->wireless menu…

Is it just me or are the SnapShot Builds on OpenWrt faulty.

Using their link - https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=mediatek%2Ffilogic&id=bananapi_bpi-r4

and downloading the SNAPSHOT (r27283-85f0128851) build to SDCard.

I can’t get any combination of enabling 2.4GHz and/or 5GHz Wifi working at all.

Yes, that is correct. @Betonmischer the Sinovoip’s OpenWrt is working but for me, quite buggy

longterm 5.4 support ends in Dec 25 hopefully will be quicker their upgrade to 6.1 (not 5.10 nor 5.15 :crossed_fingers:)

I am using latest openwrt/main and

My config:

root@bpi-r4-9611025bdb3d:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option channel '1'
        option htmode 'EHT20'
        option country 'JP'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae'
        option key 'testtest'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option band '5g'
        option channel '36'
        option htmode 'EHT80'
        option country 'JP'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae'
        option key 'testtest'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+2'
        option band '6g'
        option channel '1'
        option htmode 'EHT320'
        option country 'JP'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae'
        option key 'testtest'

root@bpi-r4-9611025bdb3d:~#

And iw output:

root@bpi-r4-9611025bdb3d:~# iw dev
phy#2
        Interface phy2-ap0
                ifindex 14
                wdev 0x200000002
                addr 96:11:02:5b:db:41
                ssid OpenWrt
                type AP
                channel 1 (5955 MHz), width: 320 MHz, center1: 6105 MHz
                txpower 23.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
phy#1
        Interface phy1-ap0
                ifindex 16
                wdev 0x100000002
                addr 96:11:02:5b:db:40
                ssid OpenWrt
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
phy#0
        Interface phy0-ap0
                ifindex 15
                wdev 0x2
                addr 96:11:02:5b:db:3f
                ssid OpenWrt
                type AP
                channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
root@bpi-r4-9611025bdb3d:~#
1 Like

On your log, there is no traffic recorded. It cannot say the 6GHz band is working. If it is working, should expect some log like this:

so far just checked beacons contain EHT - stations will be next step

And here station BE200:

root@bpi-r4-9611025bdb3d:~# iw dev
phy#2
        Interface phy2-ap0
                ifindex 32
                wdev 0x200000008
                addr 96:11:02:5b:db:41
                ssid OpenWrt
                type AP
                channel 1 (5955 MHz), width: 320 MHz, center1: 6105 MHz
                txpower 23.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       14      0       0       0       0       1500            14
phy#1
        Interface phy1-ap0
                ifindex 34
                wdev 0x100000008
                addr 96:11:02:5b:db:40
                ssid OpenWrt
                type AP
                channel 36 (5180 MHz), width: 80 MHz, center1: 5210 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
phy#0
        Interface phy0-ap0
                ifindex 33
                wdev 0x8
                addr 96:11:02:5b:db:3f
                ssid OpenWrt
                type AP
                channel 1 (2412 MHz), width: 20 MHz, center1: 2412 MHz
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0
root@bpi-r4-9611025bdb3d:~# iw phy2-ap0 station dump
Station a0:02:a5:5f:e0:65 (on phy2-ap0)
        inactive time:  460 ms
        rx bytes:       4584
        rx packets:     102
        tx bytes:       1844
        tx packets:     18
        tx retries:     17
        tx failed:      17
        rx drop misc:   0
        signal:         -42 [-46, -45, -48] dBm
        signal avg:     -39 [-43, -43, -46] dBm
        tx bitrate:     288.2 MBit/s 320MHz EHT-MCS 0 EHT-NSS 2 EHT-GI 0
        tx duration:    104259 us
        rx bitrate:     980.0 MBit/s 320MHz EHT-MCS 3 EHT-NSS 2 EHT-GI 2
        rx duration:    12014 us
        last ack signal:-42 dBm
        avg ack signal: -41 dBm
        airtime weight: 256
        authorized:     yes
        authenticated:  yes
        associated:     yes
        preamble:       long
        WMM/WME:        yes
        MFP:            yes
        TDLS peer:      no
        DTIM period:    2
        beacon interval:100
        short slot time:yes
        connected time: 67 seconds
        associated at [boottime]:       5788.042s
        associated at:  1725213233393 ms
        current time:   1725213299973 ms
root@bpi-r4-9611025bdb3d:~#
1 Like

Could you share the image of the SD?

2 Likes

Thanks, all three APs work that way. Although, I can only join them so long as encryption is off…

http://valhalla.bofh.pl/~l4mer/openwrt-mediatek-filogic-bananapi_bpi-r4-sdcard.img.gz

3 Likes

wpa2 + sae - my clients have fresh supplicant

root@bpi-r4-9611025bdb3d:~# cat /etc/config/wireless 

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option band '2g'
        option channel '1'
        option htmode 'EHT20'
        option country 'JP'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae-mixed'
        option key 'testtest'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option band '5g'
        option channel '36'
        option htmode 'EHT80'
        option country 'JP'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae-mixed'
        option key 'testtest'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'soc/11300000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+2'
        option band '6g'
        option channel '1'
        option htmode 'EHT320'
        option country 'JP'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae'
        option key 'testtest'
        option sae_pwe '2'

root@bpi-r4-9611025bdb3d:~#