BPI-R2 new image: Ubuntu with Linux kernel 4.14 release V1.0 2018-4-28


(ZB) #1

BPI-R2 Ubuntu with Linux kernel 4.14 source code release V1.0 2018-4-28

  1. Summary for this release; This release is for BPI-R2 Ubuntu OS with linux kernel 4.14 source code,you could download source code from this link:
  1. What’s new:
  • Wifi client / AP mode support
  • 4G module support
  1. Known limitations:
  • HDMI not working
  • BT/BLE not working
  1. FAQ:

    1) How to enable 4G module on R2 with kernel 4.14?

    You could see relevant info from here: How to use BPI-4G LTE module with BPI-R2

    2)How to enable wifi client?

    • wmt_loader (ignore errors)

    • stp_uart_launcher -p /etc/firmware &

    • ip link set wlan0 up

    • iw dev wlan0 scan | grep SSID

    • vim /etc/wpasupplicant/wpa_supplicant.conf

    • network={ ssid=“ssid” psk=“password” priority=1}

    • wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

    • dhclient wlan0

    3)How to enable AP mode?

    • wmt_loader (ignore errors)

    • stp_uart_launcher -p /etc/firmware &

    • echo A >/dev/wmtWifi

    • create your hostapd.conf: "vim /etc/hostapd/hostapd.conf "

      hostapd.conf (236 字节)

    • According to your network interface(can search internet) to config ap0:

      my network interface which can search internet is wan, and ip is 192.168.30.102, so I config ap0 as follows:

      “ifconfig ap0 192.168.30.188 netmask 255.255.255.0”

    • Run hostapd : “hostapd -d /etc/hostapd/hostapd.conf”

    • Config dhcp file : “vim /etc/dhcp/dhcpd.conf”

      subnet 192.168.30.0 netmask 255.255.255.0 {

      range 192.168.30.2 192.168.30.250;

      option domain-name-servers 8.8.8.8;

      option routers 192.168.30.1; }

    • Config dhcp of ap0, then the devices which connect ap0 could get IP: "dhcpd ap0 -pf /var/run/dhcpd.pid "

    • And a bridge

      brctl addbr br0

      brctl addif br0 ap0

      brctl addif br wan

    • Config br0 : “ifconfig br0 192.168.30.180 netmask 255.255.255.0”

    • Add br0 gw as : “route add -net default netmask 255.255.255.0 gw 192.168.30.1 dev br0”

    Thanks for every developer who contributes to this project, especially :

    @garywang @frank-w.


BPI-R2 OpenWrt(LEDE) Souce code : 2018-04-11
(Prakash) #3

Hi @Jackzeng Can you please exactly share the link for 2018-4-28 Ubuntu image or this release is only for kernel?.


(ZB) #4

sure, Do you want the 4.14 kernel, right?


(Prakash) #5

Yes, 4.14 kernel. I would also like to know which Ubuntu it is and how it differs from your Ubuntu 16.04 v1.3 29.03.2018 image?.


(ZB) #6

OK, I will send you later.


(ZB) #7

Here is R2 Ubuntu image with kernel 4.14,this is for test,you could compare with Ubuntu kernel 4.4 https://pan.baidu.com/s/15iCwmRX8NPCuAhHG0P8Dxw


(Petr Nosek) #8

Hi, can anybody confirm, that wifi in AP mode is stable?

I bought 2 pieces of Banana Pi. The first one was R1. The second one is R2.

It was the worst purchase I’ve ever made. R1 in AP mode will always be unstable.

I hoped, that R2 is solved and Wifi will be stable. The board has several ethernet ports - it could be good router. Everybody is expecting, that AP mode and ethernet works. It is like purchasing a new car for travelling and producer forgot to say, that the car is without engine…

Banana R2 bought in december 2017 and now is AP mode still unstable. I tried several tips, I’ve read several discusion. I found this release: BPI-R2 New Image Release : Ubuntu 16.04 V1.3 2018-3-30

With text: Known limitations - Wifi Ap is unstable. OMG - how is it possible? This information should be on the package. BPI-R2 - warning - do not use for networking…

You can see, that I’m irritated from this product and driver support. The question is. Is wifi in AP mode stable or unstable?


(Frank W.) #9

My r2 is running 50 days with ap enabled (4.14.34),used everyday and is only 1 time restarted because of a channel-change (my neighbour changed before so i got overlapping channel with bandwidth-reduction). Some people have problems with random-number-generator…


(Petr Nosek) #10

Hi Frank. Thank you for your response. And how many devices do you have connected?


(Frank W.) #11

simultanously only max 2


(Petr Nosek) #12

I will try this image, I will see.

I have network with several devices - MacOS, Android, Windows 10 (8 devices).

It seems, that after connecting windows 10 - wifi AP is broken. But not this image. My last kernel is: Linux bpi-iot-ros-ai 4.4.126-BPI-R2-Kernel

So I will try this kernel. My last try :slight_smile:


(Frank W.) #13

i’m using not this ubuntu-image i’m using my headless debian stretch :slight_smile:


(Try Infinity) #14

Can you upload to another cloud please ?


(Frank W.) #15

you can also try my headless ubuntu-image Ubuntu 18.4 with kernel 4.14.48


(Try Infinity) #16

Thank you so much! Now i try