Shutdown does not poweroff

No, shutdown -p now should also work…it’s only a habit that -h also powers off on my other systems

shutdown -P now

should be power off…but only halted (stayed on)

I assume,that acpi is not supported by default jessie-kernel full debug-log: uart_kernel_old.log (145.3 KB)

“init 0” and “poweroff” does also only halt (green led is always on) => maybe some acpi-options/kernel-modules are missing, but i did not found anything

uart_kernel_new.log (65.8 KB)

Did you check here:

Only init-level…nothing about the powerdown after system halt

Also 4.4.70 kernel does not poweroff…looked throught kernels menuconfig and googled around,but found nothing related

opened issue on github:

@garywang any news about that?

can we hope for a implementation of shutdown-function?

Jack is working on this feature. @Jackzeng

Good news… Sean submitted patch to support shutdown function. :grinning:


i will try to integrate it to 4.14 (begin with min 4, 1-3 is documentation).

the linked patch needs at least

tried to add patches 4-14 to 4.14, compiles fine, have no effect in power-control but mess up network-interfaces

don’t plug into micro usb cable.

my test seems working :slight_smile: LEDs will get dark when i enter “poweoff” command in console.

dts is also needed to be modified according to the dt-binding document.

I guess you use 4.16… i use no micro-usb. Green led stays bright and power consumption is same as without patch. I have not changed dts…only the mentioned patches

All physical ethernet-interfaces disappeared (eth,wan,lan). Seems that the patch disabled power of the ethernet-part of soc

@linkerosa you mean this (devicetree-mod in patch #1):

rtc {
+		compatible = "mediatek,mt6323-rtc";
+		power-off {
+			compatible = "mediatek,mt6323-rtc-poweroff";
+		};
+	};
  1. the first thing for net not work :slight_smile: i don’t think the patch set would allow the network driver doesn’t work.

they don’t have a direct relationship with each other

  1. the second thing for dts :slight_smile: yes. you should add power-off node under rtc node. in addition, the following patch is also required.

it would allow the rtc driver to probe the power-off driver.

you mean, in your test you have the same issue? have you tried with 4.14 or 4.16?

i tested on 4.16. but the interfaces for dsa still can be seen.

strange that the interfaces gone in 4.14…there should be not much new between 4.14 and 4.16 regarding this

here is the commit:

after check, i reverted it

@linkerosa can you reproduce the problem with the commit above? Is it my fault or incompatibility of the patches with 4.14?

poweroff Patches included in upcoming linux 5.5 (currently linux-next)

for uboot we got it working with these 2 commands:

mw 0x1000d09c 0xc0004300
mw 0x1000d09c 0xc01e0001

with some help from @ray i got poweroff-driver in uboot running

0001-poweroff-add-poweroff-to-bananapi.patch (2,1 KB)