Shutdown does not poweroff


(Frank W.) #1

Hi, i’ve installed debian jessie and (after some testing) i tried to shutdown system via “shutdown -h now”.

last message in debug-log is “System halted”, but board stays powered on (green led, blinking leds on ethernet, and red led near power-jack)

is there a way to power off? maybe shutdown can be configured to do poweroff after halt automatic (this i see on other boards)

regards Frank


(Wolfgang) #2

Hi Frank

you have already tried it with init 0

hast du es schon mit init 0 versucht


(Frank W.) #3

No, shutdown -p now should also work…it’s only a habit that -h also powers off on my other systems


(Frank W.) #4

shutdown -P now

should be power off…but only halted (stayed on)

I assume,that acpi is not supported by default jessie-kernel full debug-log: uart_kernel_old.log (145.3 KB)


(Frank W.) #5

“init 0” and “poweroff” does also only halt (green led is always on) => maybe some acpi-options/kernel-modules are missing, but i did not found anything

uart_kernel_new.log (65.8 KB)


(Wolfgang) #6

Did you check here: https://www.pks.mpg.de/~mueller/docs/suse10.0/suselinux-manual_de/manual/sec.boot.init.html


(Frank W.) #7

Only init-level…nothing about the powerdown after system halt


(Frank W.) #8

Also 4.4.70 kernel does not poweroff…looked throught kernels menuconfig and googled around,but found nothing related

opened issue on github: https://github.com/BPI-SINOVOIP/BPI-R2-bsp/issues/16


(Frank W.) #9

@garywang any news about that?


(Frank W.) #10

can we hope for a implementation of shutdown-function?


(gary) #11

Jack is working on this feature. @Jackzeng


(moore liu) #12

Good news… Sean submitted patch to support shutdown function. :grinning:https://patchwork.kernel.org/patch/10302965/


(Frank W.) #13

i will try to integrate it to 4.14 (begin with min 4, 1-3 is documentation).

the linked patch needs at least https://patchwork.kernel.org/patch/10302997/


(Frank W.) #14

tried to add patches 4-14 to 4.14, compiles fine, have no effect in power-control but mess up network-interfaces


(dorabmon) #15

don’t plug into micro usb cable.

my test seems working :slight_smile: LEDs will get dark when i enter “poweoff” command in console.

dts is also needed to be modified according to the dt-binding document.


(Frank W.) #16

I guess you use 4.16… i use no micro-usb. Green led stays bright and power consumption is same as without patch. I have not changed dts…only the mentioned patches

All physical ethernet-interfaces disappeared (eth,wan,lan). Seems that the patch disabled power of the ethernet-part of soc

@linkerosa you mean this (devicetree-mod in patch #1):

rtc {
+		compatible = "mediatek,mt6323-rtc";
+
+		power-off {
+			compatible = "mediatek,mt6323-rtc-poweroff";
+		};
+	};

(dorabmon) #18
  1. the first thing for net not work :slight_smile: i don’t think the patch set would allow the network driver doesn’t work.

they don’t have a direct relationship with each other

  1. the second thing for dts :slight_smile: yes. you should add power-off node under rtc node. in addition, the following patch is also required.

https://patchwork.kernel.org/patch/10303001/

it would allow the rtc driver to probe the power-off driver.


(Frank W.) #19

you mean, in your test you have the same issue? have you tried with 4.14 or 4.16?


(dorabmon) #20

i tested on 4.16. but the interfaces for dsa still can be seen.


(Frank W.) #21

strange that the interfaces gone in 4.14…there should be not much new between 4.14 and 4.16 regarding this

here is the commit: https://github.com/frank-w/BPI-R2-4.14/commit/1d44ffc48f7c4fcefc8360e8c153c989044dcb9c

after check, i reverted it