Official OpenWRT 18.06.4 for Banana Pi BPI-R2 image released 2019-7-04

Wow, great answer.

Is that any way to build 18.06.4 image without those “problems”? And how to build additional packages? Can you give us some manual? Or point to it?

Thanks in advance Alexey!

isn’t it possible to use ext4 as overlayfs?

18.06.4 - not so sure. 18.06.x - yep, one will have better luck using one of community-provided OpenWrt forks. Or use something like “OpenMPTCProuter”. Among other variants there’s my fork, check here:

I hadn’t had a chance to update it with latest changes to 18.06 release branch but its state it pretty close to what had been tagged as 18.06.4. And I’d expect that updating source to the latest changes would be as simple as blind merge. I’m planning to take a look onto this later on, maybe this or next weekend.

Build process is exactly the same as for any other OpenWrt image. There are plenty of guides available out there for googling. Best way to start IMHO is OpenWrt’s official wiki.

In broad understanding of “possible” - yes, it is technically possible. It is just not what is supported out of the box by OpenWrt. OpenWrt’s approach to filesystems is a hard choice: squashfs+jffs2 in overlayfs or single filesystem rootfs like ext4/jffs2. And it is reasonable as overlayfs approach fits well for devices with small amounts of onboard flash memory (like 4-8MB) while single filesystem rootfs works well for more server-like use cases. It is possible for sure to patch OpenWrt sources to implement overlayfs with squashfs + ext4 but (a) it is “to patch” thus it is not upstream provided and would require personal building of changed sources and (b) there’s no real advantage in using overlayfs with eth4 - it is faster and easier to use only ext4 instead and drop the overlayfs bit. Nevertheless enabling ext4 rootfs for BPi-R2 also requires small amount of patching to OpenWrt sources but it is way easier and had already been done in several forks (including my fork I linked to earlier),

i’ve burn initramfs.bin to sdcard, it’s boot… but i can not ping to from network to my bpi-r2…, luci =http :// no reach i try to change password, after reboot it came standard

please somebody tell me step by step install openwrt 18.06.4 to my bpi-r2

@salmon_randa, just download this in \targets\mediatek\mt7623 you will find image for sd-card and kernel-based packages.

Luci requires additional installation via the terminal, do you have a serial connection?

yes, i’ve serial connection sir i’ve install openwrt… but when i install luci with command “opkg install luci”, it’s error “Cannot install package luci” please help

@salmon_randa does you can ping from your R2?

P.S. I’m not sir. I`m comrade. :slight_smile: (it’s just a joke)

tks sir… i’m on openwrt 18.06.2 now

but i found the problem with my usb hdd… it’s won’t detect… if i use lede, it’s detect please…

opkg install usbutils

how do I install luci ?

I figured out. It’s four dd commands.


hi. can i have question ? do someone have open wrt 18.06.4 i tryied many times to compile into IMG with EXT4 but i failed.

What sources had you been using to compile this image? Official upstream OpenWRT do not support ext4 as rootfs for BPi R2.

i am now on 18.06.2 openwrt-mediatek-mt7623-7623n-bananapi-bpi-r2-ext4-sdcard.img, i tryied to compile 18.06.4 to img. not a chance i am compiling from Openwrt page. (mediatek 7623), updating from official dont work too.

This version digits and filename do not tell anything useful about their origin :-). Where did you get them?

from this G-drive page “Drive”

Aha, I see. This is an image that was built from my openwrt fork by @Tohin. I hadn’t had a chance to update my fork to 18.06.4 (as I don’t see this task to be a really urgent one) but it was done by other people. You may want to check the link below for the info on how to achieve the thing you want:

I have problems booting openwrt from emmc in the sense that after reboot, all settings are gone and the login screen tells me that there is no root password set . I tried serveral images I found on the forum, I even compiled it my self…same result.

I followed these steps :

root@bpi-r2:~# dd if=mtk-bpi-r2-EMMC_Custom_by_ME.img of=/dev/mmcblk1
156747+1 records in
156747+1 records out
80254502 bytes (80 MB, 77 MiB) copied, 10.9279 s, 7.3 MB/s

root@bpi-r2:~# echo 0 > /sys/block/mmcblk1boot0/force_ro

root@bpi-r2:~# dd if=mtk-bpi-r2-EMMC_Custom_by_ME.img of=/dev/mmcblk1boot0 bs=1M count=1
1+0 records in
1+0 records out
1048576 bytes (1.0 MB, 1.0 MiB) copied, 0.0434202 s, 24.1 MB/s

root@bpi-r2:~# ./mmc extcsd read /dev/mmcblk1 | grep PARTITION_CONFIG
Boot configuration bytes [PARTITION_CONFIG: 0x48]

root@bpi-r2:~# fdisk -l
Disk /dev/mmcblk0: 29 GiB, 31104958464 bytes, 60751872 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000ed6cd

Device         Boot  Start      End  Sectors  Size Id Type
/dev/mmcblk0p1      204800   729087   524288  256M  c W95 FAT32 (LBA)
/dev/mmcblk0p2      729088 15269887 14540800    7G 83 Linux

Disk /dev/mmcblk1: 7.3 GiB, 7818182656 bytes, 15269888 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

root@bpi-r2:~# ls -lia /dev/mmcblk*
   29 brw-rw---- 1 root disk 179,  0 Nov  3  2016 /dev/mmcblk0
13237 brw-rw---- 1 root disk 179,  1 Nov  3  2016 /dev/mmcblk0p1
13238 brw-rw---- 1 root disk 179,  2 Nov  3  2016 /dev/mmcblk0p2
13240 brw-rw---- 1 root disk 179,  8 Dec 29 21:52 /dev/mmcblk1
13243 brw-rw---- 1 root disk 179, 16 Dec 29 21:55 /dev/mmcblk1boot0
13242 brw-rw---- 1 root disk 179, 24 Nov  3  2016 /dev/mmcblk1boot1
13241 brw-rw---- 1 root disk 179,  9 Nov  3  2016 /dev/mmcblk1p1
13239 crw------- 1 root root 248,  0 Nov  3  2016 /dev/mmcblk1rpmb

Here I I booted into openwrt :

root@OpenWrt:/# df -h
Filesystem                Size      Used Available Use% Mounted on
tmpfs                   503.7M    328.0K    503.4M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev

The single error/warning I encounter on boot is the following :

UBoot 2014.04-rc1 (Mar 05 2019 - 02:09:09)
g_nr_bank = 1.
g_total_rank_size = 0x80000000
DRAM:  2 GiB
WARNING: Caches not enabled
MMC:     emmc: 0,  sdcard: 1
booting from eMMC
dev_num = 0
*** Warning - bad CRC, using default environment

Can anyone help me with a hint in my problem ? Thank in advance.

you write openwrt-image to boot0 block instead of only preloader…