How to change UART speed in preloader

Dears

Our legacy equipment has problems communicating with BPI-R2 using UART console with speed 115200. Is it possible to change console speed to get U-Boot working at 9600 ?

Regards J

Preloader is closed source so i think it’s not possible to change uart speed in an easy way…just try another uart chipset, e.g. cp21xx.profilic are known to be buggy

If you have problems, when sending many characters in a short time, a short tx delay might be a solution. I have experienced problems with copy/paste to u-boot terminal on BPI-R64 (OpenWRT is OK).

Solution: use minicom and change tx delay to 1ms for better u-boot copy/paste

in Minicom: Ctrl+A followed by ‘Z’ and ‘t’, then select ‘f’ and write ‘1’

found here:

Is there any way to save this setting (tx delay)? I googled around but it seems to be not possible,so we need to set it everytime we open a new minicom-session

Unfortunately I didn’t find a simple way to configure this setting yet.