Debug UART Connector


(Thomas Linke) #1

Well I know this is a little off-topic but I thought it might be helpful for some of you:

I was pretty fed up with fiddling around with those tiny wires when connecting my FTDI2USB cable to the debug pins. So I gave it a try and ordered a couple of Max3232 Modules like this:

max3232

50 Eurocents - 4 wires - 2 screws. Done. one for all time. works with other Bananas, Oranges … any green food :slight_smile:


(Frank W.) #2

but these need a separate usb2serial-adapter or an existing com-port, right? basicly you need an additional cable from usb to the 9pol dsub-connector


(Thomas Linke) #3

That’s true. But I already have a couple of usb2serial cables. The main advantage is that now i have a mechanically stable connection an no more tiny wires which I have to re-wire anytime I want to connect to another Banana. Just plug and play :slight_smile: You know, I’m far-sighted so I need serious lenses to find the correct gpio-pins everytime I need to connect to another board :smiley:

Besides, I wanted some kind of standard connector when I put any Banana into some 19" housing.


(Thomas Linke) #4

Hi Frank,

ich brauch mal kurz Deine Hilfe, bin vernagelt. Ich muss ganz dringend die R2 als Client einsetzen. Situation: Ich hab derzeit kein Internet. Ich darf aber beim Nachbarn an Wlan, also soll die R2 als umgekehrter WLAN-Router arbeiten.

Hast Du auf die schnelle ne Idee? Ich sehe kein wlan-device

Vielen Dank

Thomas


(Frank W.) #5

please post english in public area…

You can use wifi as client if make “echo 1” instead of “echo A” resulting in device wlanx (not ap0). With this you should make a connection to existing AP if you cannot use wired connection


(Thomas Linke) #6

Oh sorry, I wasn’t aware that it’s public. I did echo 1 >/dev/wmtwifi but no wlanx appeared.


(Frank W.) #7

Make sure between 1 and > is a space, “1>” have a different meaning. And /dev/wmtWifi is case-sensitive…

Havn’t tried it yet,but instructions for any image from @garywang are like this

Here is a log from bitmaster showing the wlan0-device (did not found the instructions from gary):


(Thomas Linke) #8

Yes there is a space :wink: sorry


(Frank W.) #9

You try to enable debugging, maybe with kernel 4.4 (have not tested this with 4.14) and compare results with bitmasters log from my last post

Configuration of the interface (de): https://wiki.ubuntuusers.de/interfaces/#WLAN-Konfiguration

http://netz10.de/2010/02/13/wlan-wpa2-mit-psk-manuell-konfigurieren/