BPi R64. OpenWrt. Dont Work Gpio, /sys/class/gpio/ Please help me

Hello. I made my own build of Openwrt. But the system does not have the / sys / class / gpio / directory. What could have gone wrong? If necessary, I will provide any information.

root@OpenWrt:/# dmesg|grep gpio [ 0.015418] gpiochip_find_base: found new base at 409 [ 0.015500] gpio gpiochip0: (pinctrl_mt7622): added GPIO chardev (254:0) [ 0.015505] gpiochip_setup_dev: registered GPIOs 409 to 511 on device: gpiochip0 (pinctrl_mt7622) [ 0.015514] gpio gpiochip0: (pinctrl_mt7622): created GPIO range 0->102 ==> 10211000.pinctrl PIN 0->102 [ 0.022889] of_get_named_gpiod_flags: can’t parse ‘gpio’ property of node ‘/regulator-1p8v[0]’ [ 0.023040] of_get_named_gpiod_flags: can’t parse ‘gpio’ property of node ‘/regulator-3p3v[0]’ [ 0.023156] of_get_named_gpiod_flags: can’t parse ‘gpio’ property of node ‘/regulator-5v[0]’ [ 0.867649] of_get_named_gpiod_flags: can’t parse ‘reset-gpios’ property of node ‘/ethernet@1b100000/mdio-bus[0]’ [ 0.878237] of_get_named_gpiod_flags: can’t parse ‘reset-gpio’ property of node ‘/ethernet@1b100000/mdio-bus[0]’ [ 0.998750] of_get_named_gpiod_flags: can’t parse ‘wp-gpios’ property of node ‘/mmc@11230000[0]’ [ 1.007813] of_get_named_gpiod_flags: can’t parse ‘wp-gpio’ property of node ‘/mmc@11230000[0]’ [ 1.097411] of_get_named_gpiod_flags: parsed ‘cd-gpios’ property of node ‘/mmc@11240000[0]’ - status (0) [ 1.124348] of_get_named_gpiod_flags: can’t parse ‘wp-gpios’ property of node ‘/mmc@11240000[0]’ [ 1.133412] of_get_named_gpiod_flags: can’t parse ‘wp-gpio’ property of node ‘/mmc@11240000[0]’ [ 1.545436] of_get_named_gpiod_flags: parsed ‘gpios’ property of node ‘/gpio-keys/factory[0]’ - status (0) [ 1.555419] of_get_named_gpiod_flags: parsed ‘gpios’ property of node ‘/gpio-keys/wps[0]’ - status (0) [ 1.565052] gpio-keys gpio-keys: failed to request irq:-6 for gpio:409 [ 1.571780] gpio-keys gpio-keys: failed to request irq:-6 for gpio:511

Is CONFIG_GPIO_SYSFS enabled?

This item is not in the .config file. What to do then?

But GPIO_SUPPORT is enabled, on other boards the same config file items give a positive result and GPIOs work

you have to set it via “make menuconfig” (or make kernelconfig in openwrt)

GPIO_SUPPORT does not export the sysfs-nodes

Thanks friend, yes for sure I found GPIO_SYSFS in make menu_kernelconfig. I’ll try to build it. I can only answer tomorrow about the GPIO, because the board is in my office.

Thanks it helped, everything works now