BPI-R2 New image : Openwrt/LEDE 2017-09-08


(sunarowicz) #35

Sorry, I do not have any experience with FT232RL adapter. But today I bought the CP2102 based adapter for little money and it works like a charm at first try. See here: https://www.gme.cz/prevodnik-usb-uart-reset-pin#product-detail.


(Maciek Szelągowski) #36

Have switched to Profilic PL-2303HX and still no luck … I will try if Ubuntu wants to talk on serial


(gary) #37

@sunarowicz

Please follow below steps to change a setting for EMMC, and then the lede image will work fine.


(Maciek Szelągowski) #38

Sorry. Everything works. I made mistake to connect serial ttl to GPIO uart instead of u-boot uart debug.


(sunarowicz) #39

Thank you gary a lot. This did the trick! Now I boot to LEDE from SD card and EMMC as well. I believe it would be useful to add this hint here: https://bananapi.gitbooks.io/banana-pi-bpi-r2-open-source-smart-router/content/openwrt.html.

So partial success so far. Unfortunately I still do not boot the Ubuntu. I moved my ask for help here (believe it is the better thread for that topic than this one):


(Maciek Szelągowski) #40

@garywang could you please compile test images every let’s say week? (I beleve someone make progress in development …)


(jackie) #41

Do I need to fat SD before carry on step 2?

I move SD card to my R2 board and then power on it, but get nothing output from debug UART.


(gary) #42

No need to format the SD, please follow below steps to change the EMMC setting.


(Sam) #43

Hello Gary I have the same issue. Please, how can we manage to still boot from Emmc and keep custom settings over any reboot ? What is the alternative ? Keeping LEDE booting on SD Card ?


(gary) #44

The squashfs and jffs2 are working fine, please check above comment for details.


#45

I just copied the image onto the sd card, and when I try to boot the banana pi R2 I just get this kind of violet screen with no prompt/console or anything like that, can you help me out?

(Same issue like @pkalemba @Tohin @Maciek_Szelagowski)


(Paweł Kalemba) #46

To Have console you need to ssh or Have a uart serial cable, as i said in post above Lede does not Have graphical interface


(Sam) #47

Hello Gary Thanks for the information. I’m trying to download the files from your Test_1023 directory since yesterday unsuccessfully. I will retry soon. Regards.


(gary) #48

It’s still available to download, please have a try.


#49

I just scanned my network and my laptop and smartphone showed up, but not the banana pi, so there’s nothing I can ssh into :disappointed_relieved:


(Frank W.) #50

Have dhcp running? Maybe you found the ip in the log of the dhcp-server

Or you can use debug-uart to login local to get ip


#51

I don’t know if dhcp is running, and I don’t know where I could possibly get the log of the dhcp-server, because I don’t have a UART-Debug adapter. I just placed a lan-cable in the very left lan(/wan) port, and turned it on. But it should be powered on, because when I place a HDMI cable in the HDMI port, I get that violet screen, and all the lights are on.


(Frank W.) #52

I mean dhcp-server behind lan-connection (existing router,not the pi itself)

as @pkalemba said, lede has no graphical interface…why no console,maybe hdmi is not supported yet.

debug-uart is the simplest way to find out what’s wrong…


(Sam) #53

Hello Gary I finally succeed in downloading and installing the files. Now my BPI R2 is up and running, and the settings are persistent. Thanks a lot for your help, i will now try to configure my router correctly. I need to learn everything about LEDE. Have a nice weekend. Regards


(Mark Curtis) #54

Hay great work but I’m having a real problem trying to get the download as I only speak English I have tried everything but I still can’t get it please help