BPI-R2 New image : Openwrt/LEDE 2017-09-08


(gary) #10

@pdoyle003 @balou1974

We guess this problem is caused by wrong partition configuration of EMMC, please following below steps to corret it:

  1. install the SD card with LEDE test image

  2. Power on the R2 board,

  3. After the u-boot prompt “BPI-R2>” occurs, please enter the command “emmc ecsd” to check partition configuration, on your board, the partition configuration should be 0h

       [EXT_CSD] Partition config      : 0h
    
  4. Then run command “emmc pconf 0x48” to change it

  5. Power off this board, remove SD card, and then power it on

Please let me know if you have any question…


#11

I can’t get the image to work, possibly because of a special situation with my BPI-R2. The Power-Switch was broken when I received my board, so I soldered in a bridge for this switch.

Loading Ubuntu 16.04 image from SD card works for me with that workaround.

I’m wondering if that might cause the problem when booting OpenWRT, because I get only a “greenish” screen during boot and nothing else happens.

Any ideas on this issue?


(gary) #12

Can you please share us the log? We’d like to see what happens on your board?


#13

Unfortunately no, because I have neither local nor remote access to the board. NICs do not even come up.


(gary) #14

Please confirm if you removed SD card after progamming LEDE image to EMMC completed.

If yes, the board is still not working, please follow steps to change a configuration:


#15

Hello. I write image to sd card. But fdisk doesn`t see any partition on Sd-card. After install sd-card to board i get the pink(or red, or purple) screen at boot. Like a pkalemba.

What am I doing wrong?

UPD: command “emmc pconf 0x48” will help!


(Manuel Roeder) #16

@garywang: Thanks a lot!!!

Your description worked like charm! LEDE/OpenWrt has booted from emmc after fixing the partitioning!


(Paweł Kalemba) #17

Hi i found none of packages i tried to install are not working. Any solution? Im a kinda newbie in LEDE


(gary) #18

Do you see something on serial port when you install SD card on which the lede image is intalled? if yes, can you please share us the log? @pkalemba


(Paweł Kalemba) #19

@garywang i was able to run Lede on my board, but installing packages with opkg shows command not found if trying to run swconfig but its marked as installed


BPI R2 LEDE(openwrt) source code
BPI-R2 LEDE source code for hardware NAT
BPI R2 LEDE(openwrt) source code
(Paweł Kalemba) #20

Can somebody give me instructons how to build own image with R2 support?


(Manuel Roeder) #21

You need bleeding edge lede buildsystem to have the option to create mediatek arm 32bit kernel and lede distribution - search for lede project and use git clone to get the latetest development version. After that cd to lede and configure the buildsystem for the mentioned mediatek system(make menuconfig). After that start building with make.


#22

I test this image and it boots well. But even I shutdown or restart the system, all settings are lost. Is there something I have to do to install openWRT/LEDE right?


(gary) #23

Hi RW2003

Now the file system is ramdisk, so your setting wil lost across reboot.


(gary) #24

Please follow above link to build openwrt image.


#25

Hello, gary.

Could you please write a summary of the current state of development? What hardware works? What does not work? What are the planned release dates of the ready-to-use version? (I mean saving the configuration, the ability to install packages from opkg, working USB and SATA)


(Maciek Szelągowski) #26

Did everything as stated but pink or white screen during boot. Had wait for 10 minutes. On SD there’s no valid partitions (checked on ubuntu gparted) any clue?


(Paweł Kalemba) #27

@Maciek_Szelagowski try uart debug , afaik LEDE does not desktop interface


(sunarowicz) #28

I`m not able to boot the image from microSD card. Not LEDE, nor Ubuntu Mate. I follow all the instructions on how to format the card and burn the image. I did it many times in Linux. Tried in Windows too. Even used two different cards. But whatever I do, the booting from card freezes soon with pink screen and green and red LEDs next to GPIO and the red one next to HDMI on. No prompt appears. Keyboard and mouse do not work. Am I missing something? Or is my BPI-R2 broken? Already two similar posts here in this thread. But no solution so far. I do appreciate any help. Thx.


#29

sunarowicz, You need to connect uart and post a bootlog here.