[BPI-R2 new image] debian 10 buster image with Kernel 4.19.62

Ah, it might be the reason u-boot was failing for me when built with ext4 and fat write support. Will give these a try.

One more question - how to make Hardware-NAT for your kernel?

hwnat is only ported to 4.14 and because of instabilities and changed framework (there exists a HW-offloading-framework in newer kernels) not ported to higher kernels. maybe @moore and @Ryder.Lee knew more. but please start a new thread for questions regarding kernel and not related to this image

Ok sorry and thanks for hep!

I have downloaded the Debian Buster 4.19 kernel build referenced on this link: http://wiki.banana-pi.org/Banana_Pi_BPI-R2 I have the ethernet ports all working but the issue comes when trying to setup wireless and make it a Access Point. I can see wlan0 and the IP i have assigned to it BUT whenever i lose power or reboot i have to reconfigure it all over again. Also I cannot see the SSID when searching from other wireless devices. Frank has been very helpful in assisting me but was wondering if anyone has a blow by blow on what exactly to do in order to get the wireless up and running and making it an access Point? I would be very grateful!


This page links to my buster-image…

try to unpack this in rootfs: https://drive.google.com/drive/u/0/mobile/folders/1WLWAR1FC-rF4n2SgFecBlU1ym_XKqAR_/15Y5Y3NAOwg_IMmN3k6hdb7pAQj9oTVTl/15lHk7IEyVyQdYzVfvPvV-3jMhz7GSL7p?usp=drive_open&sort=13&direction=a

And then run wifi.sh

Frank that link takes me to your Google Drive but i dont see your buster image. I only see 5 Items in there they are as follows: r2_wifi_firmware.zip , r2_wifi_helper.zip, wifi_helper.tar.gz, wmt-tools+script.tar.gz, wmt-tools+script+conf.zip Thats is all I see nothing labeled buster -Brian-

Just unpack wmt-tools+script+conf.zip over the buster-rootfs (after burning the buster-image you allready have)

Frank… THANK YOU that got the access point running. Istill isnt persistant however i have to run that script each time the BPI-R2 loses power or reboots however. Now to try to bridge the ap0 and lan0@eth0 so I can share the Internet coming in on lan0@eth0.


just put the script in rc.local after creating/install it

steps should be same as in debian 9: https://www.itechlounge.net/2017/10/linux-how-to-add-rc-local-in-debian-9/

do not bridge ap0 with any other network-device…make separate subnets and do routing between


Thanks again Frank going to tackle the bridge thing in an hour or so…appreciate your assistance couldn’t have done it without you!

Thought I had a handle on how to get this BPI-R2 routing set up its kicking my ass. I am not giving up on this…

Your mainrouter have to know that your wifi-subnet is reachable via r2s lan ip…so you need static route on it…else packets go out,but response goes to your mainrouter and not further (or gets routed via defaultroute = back to internet)

Here is my current setup DSL Router NAT IP Schema ( )

BPI-R2 Schema lan0@eth0 BPI-R2 AP Schema ap0

I have created a static route on the DSL Router as follows Destination IP Address = (BPI-R2 ap0) IP Subnet Mask = Gateway Address = (lan0@eth0 on BPI-R2) Metric = 2

On the BPI-R2 for routes I have: dev lan0 proto kernel scope link src dev ap0 proto kernel scope link src

While from the BPI-R2 I can ping my DSl Router ( I cannot ping in the other direction.

Obviously my perspective on settings is flawed can you assist?


static route has to be defined as this: (network-address not ip-address) is reachable via

Ping between these 2 hosts should not be affected only traffic going over both ones. Don’t forget to set default route on wifi-client ( and r2 (

OK got default route set on BPI-R2 as follows:

root@bpi-r2:~# ip route show default via dev lan0 onlink dev lan0 proto kernel scope link src dev ap0 proto kernel scope link src

Now while I can ping everything from both directions ( 172.16.42.xx and 192.168.10.xx ) when my Phone Connects to BPI-R2 ap0 it says “no internet” and sure enough when trying to access gmail or facebook etc… It doesnt refresh like it has no Internet. While connected with my phone and Data connection is turned off I cannot ping or www.google.com. However when I ssh into the BPI-R2 on the ap0 I can ping and www.google.com


Is there someway to upgrade from debian 9 to 10? I don’t want to reinstall all the packages

Here is my kernel info:

uname -a
Linux BPI-R2 4.14.122-bpi-r2-main #1 SMP Thu Jun 6 17:46:54 CST 2019 armv7l GNU/Linux

btw, i have an issue. If i add mac-address in bpi-r2-mac.dts, I can get well performant. But with random macaddress and change 802-3-ethernet.cloned-mac-address in NetworkManager. I could not get more then 10Mpbs

Imho you can upgrade the normal debian way by changing the apt-sources,but this makes not a clean system and maybe break your ols one…so i prefer a fresh system and have old as backup.

You use dto in uboot? Else mac.dtb isn’t loaded…which kernels have you tried (maybe 4.19,5.x-phylink)?

You can ssh from your phone to r2 and dns/ping works from there (r2).

Can you ping your mainrouter from your mobile device? if not: Can you ping lan0-address of r2?

If also not: Have you enabled v4-routing on r2 (needs to be done every boot if only used the echo)? Make it permanant with sysctl.conf have you set default route for wifi-devices set to r2’s ap0-address?

Because The R2 is my NAS and home media center and network base server. Too many package are installed. Maybe i will not upgrade it, but performace is necessary for me.

Thanks frank-w :grinning: