BPI-R2 LEDE source code for hardware NAT


#21

I think this problem is not like that. I have intenet now. And did not change any things in “/etc/config/firewall”. Actually I just change the ifname for “wan” and “wan6” in the "/etc/config/network" to “wan” but not “eth1”. And it works.


(dorabmon) #22

Could you send pull request back to github. Lets us make support lede better.


#23

There is no wifi available yet, right?


(Frank W.) #24

Wifi-ap-driver is currently in testing state for debian-kernel (4.4.70)


(Paweł Kalemba) #25

Install commands not work… ‘cannot Install package’


(gary) #26

Do you mean that both luci-theme-bootstrap and luci-mod-admin-full can’t be installed, right?


(Paweł Kalemba) #27

Yup, some packages can be installed eg. curl but some cannot eg. htop


(Sam) #28

Cannot download the image ! : http://pan.baidu.com/s/1nuXqAVJ


#29

can’t download uImageLede by this link. root.squashfs downloaded without problem.


(Sam) #30

Hello Tohin, I succeeded selecting both files and clicking on the Download button on the top of the page. You should retrieve a zip file including both files. I had the same problem trying to donwload the files one by one …


#31

There is a new problem. I cant change my macaddr in either Luci or "/etc/config/network". Ones I change it, it cant get any IP with dhcp. Just like dead. Even I use static IP, i still can`t ping my gateway.

Another question: The mac of “wan@eth1” changed in each boot. My network have IP-MAC bind. I need a stationary MAC so that i can use the internet.

Please fix it.

Add: It can get Ipv6 address. And it can also send DHCP Discover. The MAC is which i write in “/etc/config/network”. But it don’t get DHCP Offer packet or just drop it.

ps:I don’t know how to write pull request. Sorry for the inconvenience.


#32

Hello. Tell me please how to set ip-address and netmask in uboot-shell?


(gary) #33
  1. Set IP Address
    1. Use DHCP U-Boot> dhcp
    2. Or use static IP address U-Boot> setenv ipaddr setenv netmask

2.Configure server IP U-Boot> setenv serverip

  1. If the R2 board and server are not in same local area network, you need to configure the gatewayip.

#34
Hit any key to stop autoboot:  0
BPI-R2>
BPI-R2> dhcp
Unknown command 'dhcp' - try 'help'
BPI-R2> setenv ipaddr
BPI-R2> setenv ipaddr 192.168.2.150
BPI-R2> setenv netmask 255.255.255.0
BPI-R2> ping 192.168.2.1
Enter mt7623_ethifsys_init()
[mt7623_pinmux_set]start
[mt7623_pinmux_set]end

 Waitting for RX_DMA_BUSY status Start... done

Enter setup_internal_gsw()
MT7530 Reset Completed!!
change HW-TRAP to 0x1015edf
 Release MT7623 RXC Reset
Using Eth0 device
ping failed; host 192.168.2.1 is not alive

Doesn’t work. I tried to connect the patch cord in turn to WAN and LAN ports.The gateway is not available.


(gary) #35

Hi Tohin

Sorry, the cmd dhcp isn’t included in our Uboot .

can you please confirm if the cable is connected to one of interfaces lan1-4? And what’s status of the link?, up or down?


#36

Yes, I tried to connect the patch cord in LAN ports. according to led on port, link is up.


(gary) #37

Can you please run command to saveenv to save environment variables and then reset? Also please share me all environment variables(run command printenv to show them).


#38

I think I have a problem with switch. I boot to previous version LEDE and try to connect LAN:

root@LEDE:/# ifconfig
eth0      Link encap:Ethernet  HWaddr 86:E8:E3:B0:C3:C7
          inet addr:192.168.2.150  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::84e8:e3ff:feb0:c3c7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:145 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:27379 (26.7 KiB)  TX bytes:1646 (1.6 KiB)
          Interrupt:68
[  215.588820] mt7623-gsw gswsys@1b100000: port 4 link up
root@LEDE:/# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 eth0
root@LEDE:/# ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2): 56 data bytes
**ping: sendto: Network unreachable**

printenv.txt (2,7 КБ)

Can I use eth1 in uboot by setehv ethact Eth1? (update: It doesn’t work. after reset I see eth0 in env)

After all experiments I loosed link in Uboot… Update2: Link is up after command “tftpboot”

I really don’t know how I did it.

 BPI-R2> ping 192.168.2.1
 Using Eth0 device
 host 192.168.2.1 is alive

(Frank W.) #39

root@LEDE:/# ping 192.168.1.2 PING 192.168.1.2 (192.168.1.2): 56 data bytes ping: sendto: Network unreachable

vs.

BPI-R2> ping 192.168.2.1 Using Eth0 device host 192.168.2.1 is alive

In the 1st test you pinged the wrong ip…router is in net 2.x,ping to 1.2


#40

My bad. Sorry.

solved:new trouble

After all I flashed r4757-700175b to BPI. But here new trouble. I connect WAN (I understand correctly that WAN=eth1?) to my old router with dhcp (network 192.168.2.x).

On BPI I have no IP-address:

root@LEDE:/# ifconfig eth1
   Link encap:Ethernet  HWaddr 1A:F8:2C:C0:4C:12
      inet6 addr: fe80::18f8:2cff:fec0:4c12/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:1 overruns:0 frame:0
      TX packets:1268 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:0 (0.0 B)  TX bytes:403209 (393.7 KiB)
      Interrupt:205

If I set IP manually, network doesn’t work.

 root@LEDE:/# ifconfig eth1 192.168.2.242 netmask 255.255.255.0 up
 root@LEDE:/# ping 192.168.2.1
 PING 192.168.2.1 (192.168.2.1): 56 data bytes
 ^C
 --- 192.168.2.1 ping statistics ---
 5 packets transmitted, 0 packets received, 100% packet loss

solution:

root@LEDE:/# ifconfig wan up
root@LEDE:/# udhcpc -i wan