BPi-M2U - problem with EMMC


(Tomáš Lintner) #1

Hello everyone,

I have a problem with my BPi and burning Debian to EMMC. When I upload to SD Debian 2016-09-27, I can boot without problems. But I do not see the EMMC partition over fdisk -l. I tried to copy to SD Debian 2016-11-29 and Ubuntu 2017-05-25, but neither one works. I end in the boot loop. Can I ask for help?


(ROBIN) #2

i have the same problem. i cannot even complete copying. it freezes or reboots.


(bpi team) #3

are you test this image??


(facat) #4

Cannot reply you in mail, so I reply here.

Yes, I tested that image. The instability problem still exists. After I increased voltage in sys_config.fex, my bsp_m2u has ran normally for 5 days. I think this is about voltage settings in sys_config.fex. It has nothing to do with images.


(bpi team) #5

can you share what you changed , so i can noted to our R&D. thank you , for you hardwork.


(facat) #6

I tweak some value in sys_config.fex and compile my kernel. See facat/BPI-M2U-bsp


#7

Hi Facat, I’ve just buy this board and I have the same problem about the instability and moreover video output blinking on many tv/monitor devices linked with different hdmi cable. by the way I’ve tried to follow your pdf guide in the repo but I’m not compleately confident on kernel complile. please could share on send me an image ready to be installed? Thank you in advance. Regards


(facat) #8

@Marco Absolutely OK. Please visit BPI-M2U kernel images to download.


(bpi team) #9

thank you , for we now update allwinner TinaLinux new version to our github , so we add your code to our github , and i have see you build your github , it very cool ,thank you for you hardwork.

PS ,it you need some others banana pi sample , we can send to you . thank you again.


#10

Hi Facat, thank you so much for the files, I really appreciated it. now I only have to find a way to build the SD but I hope that there is around on internet some guide which explains how to make it. many thanks again. Marco


#11

Hi again @facat,

I did my bootable SD as per your guide but when I put it into Bpi I got these errors during the boot sequence:

CPU3: stopping

CPU: 3 PID: 0 Comm: swapper/3 Not tainted 3.10.65-BPI-M2U-Kernel #3

CPU0: stopping

CPU: 0 PID: 0 Comm: swapper/3 Not tainted 3.10.65-BPI-M2U-Kernel #3

then 10 seconds after reboot

what could it be ? thanks in advance Marco


(facat) #12

Sorry, I have no ideal why your m2u failed to boot.

What images do you use? I’m using 2017-05-25-raspbian-jessie-preview3-bpi-m2u-sd-emmc.img.zip.


(facat) #13

I don’t see you recent commitment adds my code, so I make a pull request.


#14

Hi Facat,

yes that one…by the way now I have fixed that problem and now start correctly, there was a problem with partitions. syslog file, messages file and kernel file are growing very faster and have filled whole partition. I see many kernel errors, by the way the workaround which I’ve put in place is to exclude a specific string from put in log file. in this matter the syslog file doesn’t grow no more but after one day that the board was turned on it has freezed again. I don’t know what to do, I suppose that there isn’t a stable release up to now. I’ve asked to reseller for a refund. I’m really angry about I thank you for your help @facat . Regards