Banana pi BPI-R2 source code open on github

(bpi team) #1

Banana pi BPI-R2 source code open on github

(Aaron Gray) #2

How do I actually get this working to produce an image file for myself please. Could you give explicit instructions in the file please ?


I posted a few guidelines here, it might help you:


When I run ./, I got errors:

Makefile:961: recipe for target ‘drivers’ failed make[1]: *** [drivers] Error 2 make[1]: Leaving directory ‘/home/liu/project/bpi-r2/BPI-R2-bsp/linux-mt’ Makefile:50: recipe for target ‘kernel’ failed make: *** [kernel] Error 2

Would anybody give some suggestion? Thanks!

(Frank W.) #6

please post your full log…maybe you have not installed some requirements (gcc-arm-linux-gnueabihf, u-boot-tools)


select mode 1. log file: build.log (4.2 KB)

(Frank W.) #8

have you install requirements?

fatal error: linux/compiler-gcc7.h: No such file or directory

looks like gcc-arm-linux-gnueabihf (or something from gcc-core) is missing


I installed the tools:

arm-linux-gnueabihf-gcc --version

arm-linux-gnueabihf-gcc (Ubuntu/Linaro 7.2.0-6ubuntu1) 7.2.0

Copyright © 2017 Free Software Foundation, Inc.

This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

(Frank W.) #10

which host-system do you use to build? recommended is ubuntu 16.4, i had build successful on ubuntu 14.4

maybe you have to use gcc6


My host is Ubuntu 17.10.


FYI i had to do some manual fixes to get it compiling with gcc7, I don’t have access to a patch right now, but they are quite easy to do. However you could also use gcc6 of course, that should work out of the box.

(sunarowicz) #13

Guys, do you have any plans to provide R2 source code for Raspbian as well? I tried the Rapsbian image from and liked it much. It uses less RAM and CPU power and behaves more responsive then Ubuntu image. Raspbian seems to be a better choice for ARM based board then Ubuntu to me. Don’t you think so?

(gary) #14

We just validate the building proccess on Ubuntu 16.04 64bit, can you please try this OS on host. And the version of arm-linux-gnueabihf-gcc is newer than I’m using, gcc version 5.4 is recommended.


Thank you all! I finally build successfully on Ubuntu 16.04.