802.11ac 4x4 standard size mini pcie card is launched

it needs special tool to update efuse. I’ll suggest you ask BPI to send you new sample because your efuse is empty.

[how to enable 2 wireless interface - example by openwrt]

  1. root@OpenWrt:/sys/kernel/debug/ieee80211/phy0/mt76# echo 1 > dbdc
  2. modify /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '6'
        option hwmode '11g'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtn'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/18000000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option htmode 'VHT80'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtac'
        option encryption 'none'
  1. type ‘wifi reload’ command
1 Like

i guess step1 is same on debian/ubuntu (linux generic)? and then i get 3 wifi-interfaces (radio0+1+2, i guess radio1 is mt7622 and 0+2 are mt7615) which can be configured independently

your config makes use of wifi-device and wifi-iface…what is the difference in linux generic? it looks like HT20 needs to be disabled on 2G and VHT80 needs to enabled on 5G

Mt7622 also needs efuse to get >21dB tx power. I guess it’s not that difficult to load eeprom-data from file instead of mtd-partition (if we use the right functions to load the file - i guess request_firmware is not).

Hi,

In a general case, you can run mt7622 for 2ghz and mt7615 for 5gz (4x4)

If you want one mt7615 card to run 2ghz and 5ghz simultaneously, you need to enable the dbdc feature, which creates two phys for one card. In this case, the two phys can only run on 2ghz (2x2) and 5ghz (2x2), respectively

Last case (using dbdc) was what i want to do (if card is available in/for germany). But on debian host…will driver create 2 wifi-devices after echo dbdc to driver (first step in moores tutorial)?

Yes, it should also create another phy after echo dbdc.

got a card (thanks to paul) and found a bit of time to insert it into my r2 and make a quick bootup

root@bpi-r2:~# dmesg | grep mt7615
[   11.234552] mt7615e 0000:01:00.0: enabling device (0140 -> 0142)
[   11.308282] mt7615e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a                                                    
[   11.374026] mt7615e 0000:01:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649                                               
[   11.405305] mt7615e 0000:01:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190121161307                                              
root@bpi-r2:~# ip a                                                                                                                            
...
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                         
    link/ether 00:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff                                                                                         
root@bpi-r2:~# echo 1 > /sys/kernel/debug/ieee80211/phy0/mt76/dbdc                                                                             
root@bpi-r2:~# ip a                                                                                                                            
...                                                                                 
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                         
    link/ether 00:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff                                                                                         
10: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                        
    link/ether 82:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff

Used firmware from here and copied it to /lib/firmware/mediatek and used 5.9-main

@nagi are the antenna-connectors defined to specific phy? Currently i have only connected wf0 and 2 phy (wlan0+1) can i use hostapd on both devices with 1 antenna (for testing)? Is wlan0 2.4ghz and wlan1 5ghz or reversed? Or can both bands assigned to both phy? How to set ht20 for 2g4 and vht80 for 5g?

WF0-1 are for phy0, and WF2-3 are for phy1. You can only enable 2.4ghz on phy0, and 5ghz on phy1 simultaneously.

I think you can try to prepare hostapd_phy0.conf and hostapd_phy1.conf, and enable both of them

1 Like

I guess (v)ht is enabled by these options in hostapd-config

hw_mode=a
ieee80211n=1
require_ht=1
ieee80211ac=1
require_vht=1

https://blog.fraggod.net/2017/04/27/wifi-hostapd-configuration-for-80211ac-networks.html

I’m confused why n is enabled for a mode…i guess i need to enable ieee80211n=1 and require_ht=1 on phy0 and require_vht=1 on phy1

We are developing standard size mt7915 mPCIe card, and will be launched next month.

1 Like

Hello moore,

would you mind telling me, is the standard size mt7915 mPCIe card launched yet?

Moore wrote lanch is next month…after that i guess it takes some time before start selling (manufacturing enough parts)

Hi, is this the card you were talking about?

Yes, we can get sample next week and start the test, thanks.

i tested dbdc after reboot (anywhere it was stated it does not work and needs a poweroff, did not found the thread) on my r2 with this card (mt7615 standard size).

i can boot 5.10.0-main (see wlan0 only), enable dbdc

echo 1 > /sys/kernel/debug/ieee80211/phy0/mt76/dbdc

see now wlan0 and wlan1. now reboot (no poweroff) to same kernel, did same steps with same result

my 5.10-main is only modified to add the eeprom-file patch…

Edit: found article with reboot-problem with dbdc:

hm,is this card is 4x4:4 MU MIMO OFDMA ? how so that it is only 2401Mbps, is it combined speed of 2,4 and 5G? thnx can you please explain this: is it SU-MIMO or MU-MIMO? " MU-MIMO configurations of

  • 4 users: 4*1ss
  • 3 users: 2 1ss + 1 2ss or 3*1ss
  • 2 users: 2 2ss or 1 1ss + 1 2ss or 2 1ss"

i " * 4T4R with support of up to 2401Mbps PHY rate

  • Configurable 4×4/3×3 or 2x2n+2x2ax DBDC"

I believe @moore can give more details.

1 Like

Yes, it is mt7915a dualband selectable MU-MIMO card which can work at 4x4 2.4G (1200Mbps) or 4x4 5G(2400Mbps). If you use R64 with one 7915 card, it can become ax3200 router because 7622 has builtin 2.4G 4x4n (800Mbps) + 5G 4x4ax 2400Mbps=3200Mbps.

https://www.acwifi.net/11414.html

For dualband concurrent mode, mt7915d can be configured as 2x2 5G(1200) + 2x2 2.4G(600). It means we can have ax1800 concurrent router by only use 1 pcie slot.

AsiaRF has plan to have such card in the future. (chip is mt7915d with different pcb board)

Update progess… Just got sample and under test…

Update RvR (Rate vs. Range) test result

1 Like

I received my card with a metal shield. I was planning on adding radiators to the 2 chips on the board.

Is the shield for cooling purposes or it helps with interference?