802.11ac 4x4 standard size mini pcie card is launched

BPI-R64+7615 = AC2600

BPI-R64+7615x2=AC4300 tri-band router

Upstream driver https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/tree/drivers/net/wireless/mediatek/mt76

oh, standard fullsize

that makes it interesting for r2 too, does mt76-driver support 2 interfaces (to launch 2 hostapd, one for 2G4 and one for 5GHz)?

35$ is also ok if it works stable and driver supports dual-AP, but shipping to germany too expensive (45$)

Looks good. Hope to see 7915 soon in the same format as well.

Yes, upstream driver support DBDC (dual band dual concurrent) mode.

1 Like

Mt7915 mini pcie card is under verification, but it is not standard fullsize.

Nice, but it seems it is currently only available on asiarf where shipping is expensive.

Btw. Is eeprom problem fixed? Needs mtd partition and can only hold one eeprom (or need multiple partitions/offsets)? Eeprom should be also loadable by file from /lib/firmware like firmware,but driver does not support it. As mt7622 wifi needs also eeprom to increase tx-power this will be a problem

There is a internal flash (efuse) inside mt7615, so upstream will read calibration data from it.

Maybe I can use some pcie adapter cable, to make it fit in r64 case.

can i write this flash? ryder means that my efuse was empty so i cannot use my card (before driver was upstreamed)…card was not from bpi. i got it from a friend for testing the driver, but had no luck because efuse was empty (bpi-version was also no standard-full size)

does upstream driver creates 2 wireless-interfaces or how to bind 2 hostapd on it? somewhere here in forum i read about virtual interfaces which can be created with iw tool anyhow (debian way :slight_smile: )

it needs special tool to update efuse. I’ll suggest you ask BPI to send you new sample because your efuse is empty.

[how to enable 2 wireless interface - example by openwrt]

  1. root@OpenWrt:/sys/kernel/debug/ieee80211/phy0/mt76# echo 1 > dbdc
  2. modify /etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option channel '6'
        option hwmode '11g'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtn'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/18000000.wmac'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option htmode 'VHT80'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrtac'
        option encryption 'none'
  1. type ‘wifi reload’ command
1 Like

i guess step1 is same on debian/ubuntu (linux generic)? and then i get 3 wifi-interfaces (radio0+1+2, i guess radio1 is mt7622 and 0+2 are mt7615) which can be configured independently

your config makes use of wifi-device and wifi-iface…what is the difference in linux generic? it looks like HT20 needs to be disabled on 2G and VHT80 needs to enabled on 5G

Mt7622 also needs efuse to get >21dB tx power. I guess it’s not that difficult to load eeprom-data from file instead of mtd-partition (if we use the right functions to load the file - i guess request_firmware is not).

Hi,

In a general case, you can run mt7622 for 2ghz and mt7615 for 5gz (4x4)

If you want one mt7615 card to run 2ghz and 5ghz simultaneously, you need to enable the dbdc feature, which creates two phys for one card. In this case, the two phys can only run on 2ghz (2x2) and 5ghz (2x2), respectively

Last case (using dbdc) was what i want to do (if card is available in/for germany). But on debian host…will driver create 2 wifi-devices after echo dbdc to driver (first step in moores tutorial)?

Yes, it should also create another phy after echo dbdc.

got a card (thanks to paul) and found a bit of time to insert it into my r2 and make a quick bootup

root@bpi-r2:~# dmesg | grep mt7615
[   11.234552] mt7615e 0000:01:00.0: enabling device (0140 -> 0142)
[   11.308282] mt7615e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20180518100604a                                                    
[   11.374026] mt7615e 0000:01:00.0: N9 Firmware Version: _reserved_, Build Time: 20200814163649                                               
[   11.405305] mt7615e 0000:01:00.0: CR4 Firmware Version: _reserved_, Build Time: 20190121161307                                              
root@bpi-r2:~# ip a                                                                                                                            
...
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                         
    link/ether 00:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff                                                                                         
root@bpi-r2:~# echo 1 > /sys/kernel/debug/ieee80211/phy0/mt76/dbdc                                                                             
root@bpi-r2:~# ip a                                                                                                                            
...                                                                                 
9: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                         
    link/ether 00:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff                                                                                         
10: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000                                                        
    link/ether 82:0a:52:05:c9:e2 brd ff:ff:ff:ff:ff:ff

Used firmware from here and copied it to /lib/firmware/mediatek and used 5.9-main